はじめに

クロノスターをご利用いただきまして、ありがとうございます。

情報は共有し活用することによって、その価値は何倍にも大きくなります。クロノスターは、ファイリングシステムとして情報を整理、蓄積するだけでなく、その共有と活用をサポートするソフトウェアとして作成されました。

これからの情報化時代では、形態の異なった大量の情報が氾濫するようになるでしょう。また、私たちには、情報をコントロールし、利用する能力が求められるようになるでしょう。クロノスターが、新しい情報化時代を生き抜くためのツールとして、お役に立つものと確信しております。

クボタシステム開発株式会社
クロノスター開発チーム一同

商標

Microsoft, Windows, Windows 2000 Server, Windows 2003 Server, MicrosoftWord,
MicrosoftExcel, MicrosoftSQLServerは、Microsoft
Corporationの登録商標です。

注意

本製品の一部または全部を弊社の書面による許可なく複写・複製することを禁じます。

本製品の使用には、弊社のライセンスが必要です。

本製品の内容・仕様は、予告なく変更される可能性があります。

本製品およびマニュアルの内容には万全を期しておりますが、運用した結果の影響については責任を負いかねますのでご了承ください。

Copyright©2000-2010

            KUBOTA Systems Inc.
All rights reserved.


使い始める前に

1. 使い始める前に

クロノスターをお使いいただく前にご理解いただく必要のある概念や機能を説明しています。クロノスターを効率よく使用するために、本項をご活用ください。

1.1 システムについて
    - サーバ／クライアント構成
1.2 ファイルについて
    - ファイルの管理方法
    - ファイルの状態
1.3 属性について
    - 属性のタイプ
    - ユーザ設定属性
    - システム設定属性
1.4 フォルダについて
    - フォルダの考え方
    - ３つのフォルダシステム
    - システムフォルダ
    - バーチャルフォルダ
    - ワークフォルダ


システムについて

1.1 システムについて

サーバ／クライアント構成

クロノスターシステムは、ファイルを保存して管理するためのサーバシステムとファイルを操作するためのクライアントから構成されます。サーバとクライアントは、通常ネットワークで接続されており、必要に応じてファイルを相互に転送します。ファイルをクロノスターに登録する作業は、クライアントで行われます。クライアントで登録されたファイルは、サーバシステムに転送され、その管理下に置かれます。ファイルがサーバに登録されるとそのファイルは複数のクライアントから検索・参照・編集等の操作が可能となります。

サーバシステム上でクライアントを動作させるスタンドアローンタイプの運用もできます。

次へ


ファイルについて

1.2 ファイルについて

ファイルの管理方法

クライアントから登録されたファイルは、サーバ上で保存・管理されます。サーバ上に保管されるのは、ファイルの実体と管理情報です。管理情報は、ファイル名や作成者などファイルが基本的に持っている情報や登録時にユーザが設定した属性値などから構成されます。この管理情報は、ファイルの実体とは別にMicrosoftSQLServerにより管理されます。このＳＱＬサーバに管理されたファイルの情報は、クライアントからファイルを検索する際に使用されます。
また、クロノスターは、登録時に自動的にサムネイルと呼ばれる縮小画像を作成します。このサムネイルは、視覚的にファイルを検索するのに役立ちます。サムネイルは、文書ファイルの表紙やイメージデータを縮小して圧縮した（ＪＰＥＧ）ファイルですから、ネットワークで接続されたクライアントでも、非常に高速に表示することが可能です。

ファイルの状態

ファイルの管理情報の中には、ファイルを効率よく管理するためにクロノスターが設定した情報があります。たとえば、クロノスターでは、あるファイルとそのファイルと関連するファイルをリンク情報として管理します。その他にもチェックイン・チェックアウト情報や承認状況など高度にクロノスターを使いこなす場合に必要となる情報も管理しています。これらのファイルの状態は、ファイルごとに表示・確認できます。


属性について

1.3 属性について

属性のタイプ

ファイルに付加される属性情報は、登録後にファイルを分類し、検索するために利用されます。属性情報がなければ、登録されたファイルの中から、目的とするファイルを効率よく探し出すことができません。ファイルを整理して保存し、共有するという機能を十分に利用するためには属性情報を付加することが重要です。
この属性情報には、大きく分けて２つのタイプがあります。ひとつは、ユーザが自由に設定できる属性です。もうひとつはシステムが自動的に付加する属性です。

ユーザ属性

ユーザは、様々な種類の属性（文字属性・数値・日付など）を自由にファイルに付加することが可能です。登録されたファイルを効率よく参照するためには、的確に分類整理され、検索しやすい属性をつけることが重要です。しかし、ファイルに各個人で独自の属性を自由に付けると、本人にしか理解できない属性や、本来同じ分類であるべきものが違う分類となってしまう等の弊害が発生します。クロノスターでは、ユーザが使用する属性体系をシステム管理者が設定し、ユーザは、その設定された属性から選択して設定することができるようになっています。
ここでは、属性の体系がどのように構成されているかをご説明します。

属性グループ
属性分類の最上位のレベル。
属性を大きく分類するためのグループです。例として示した「動物」や「植物」などの分類がこの属性グループに該当します。それぞれのグループには、全く異なった属性項目が設定できます。
属性項目
属性の分類項目。
分類したい属性の種類をあらわします。「動物」属性グループの「行動様式」や「食物」などが該当します。
属性値
各属性項目のとる値。
属性項目の具体的に設定される値です。「行動時間」の「昼行性」・「夜行性」や「食物」の「肉食」・「草食」・「雑食」などの個々の値が属性値となります。

クロノスターでは設定できる属性項目の数に制限がありませんので、自由に属性項目数を増やすことができます。属性項目の数が多い場合でも、属性項目を効率よく操作するために、クロノスターでは属性項目をサブ属性グループという階層を設けて管理します。

サブ属性グループ
属性項目のグループ。
いくつかの属性項目を一つのサブ属性グループにまとめます。関連する属性項目をサブ属性グループにまとめることで属性項目自体が整理されます。

属性グループ・サブ属性グループ・属性項目・属性値の関係をご理解いただくために構成の例を以下に示します。

属性グループ | サブ属性 | 属性項目 | 属性値
デザイン | 基本 | メディアタイプ | DVD-RAM | DVD-ROM | CD-R | MO | CD
 |  | 作成者 | 鈴木 | 森 | 新田 | 浅野 | 村岡
 |  | 状況 | 未着手 | 製作中 | 完了 | 承認待ち | 承認済み
 | スタイル | 色 | 白 | 赤 | 青 | 緑 | 黄
 |  | 形状 | 丸 | 四角 | 三角 | 不定形 | Ｘ
 |  | フォント | 明朝 | ゴシック | 丸ゴシック | Ｘ | Ｘ

システム属性

クロノスターは、登録されるファイルが持っている情報を登録時に自動的に抽出し、属性値として設定します。また、クロノスターは登録後の処理によって変化するファイルの状態も属性として管理しています。
登録時に自動的に抽出される属性には、ファイルの名前やサイズ、作成日などのファイル属性と、そのファイルを生成したアプリケーションがファイル内に設定したアプリケーション属性があります。ファイル属性は、すべてのファイルに設定されますが、アプリケーション属性は、Microsoft Wordなどの特定アプリケーションのファイルにのみ設定されます。また、アプリケーション属性は、アプリケーションごとに内容も異なります。
さらにクロノスターのリンク機能や承認機能、チェックイン・チェックアウトなどの操作を行ったときのファイルの状態を示す状態属性があります。

ファイル属性
ファイルが持っている属性（Windowsが設定）
ファイルの名前やサイズ、作成日、所有者(登録作業を実施したログインユーザ名)などすべてのファイルが基本的に持っている情報を抽出したものです。
アプリケーション属性
ファイルが持っている属性（アプリケーションが設定）
ファイルを生成したアプリケーションがファイルに独自に付加した情報を自動的に抽出したものです。
状態属性
クロノスターが設定する属性。
クロノスターのリンク機能や承認機能などを使用することによって変化するファイルの状態がファイルの属性として設定されます。
システム属性は、直接変更することはできません。


フォルダについて

1.4 フォルダについて

フォルダの考え方

クロノスターのフォルダは、Windowsのフォルダとは考え方が少し異なっています。
Windowsのフォルダは、ディスクなどの記憶装置内にファイルを整理するために作った箱といったイメージになります。ファイルを一旦フォルダに格納するとそのファイルは常に同じフォルダに見えることになります。どんなファイルもフォルダに自由に格納できますが、ファイル自体は管理されていないので、ファイルを探すときは、箱（フォルダ）の名前や存在する場所などを覚えておかなければなりません。ファイルを格納した人は目的のファイルを探すことができても、他の人が目的のファイルを見つけ出すことは、非常に困難になります。さらに、ファイルが多くなってくるとファイルを格納した本人でさえもどこに格納したのかわからなくなってしまいます。
クロノスターは、データベースを使用してファイルを個々に属性で管理しています。ファイルは格納された場所ではなく、付加された属性で整理されます。このため、クロノスターでは属性値を使ったフォルダシステムを用意しています。簡単に言えば、同じ属性をもったファイルが同じフォルダに集められて表示されます。
このようなフォルダを実現するためにクロノスターでは、フォルダが開かれるとデータベースを検索し、そのフォルダに指定された属性に従ってファイルを集めて表示しています。つまり、ユーザはファイルがどこにあるかを意識しなくても、ファイルに正しい属性を付加しておけば常に整理された形でファイルを検索できるようになります。たとえば、他の人が新しく登録したファイルでもフォルダに指定された属性値にマッチしていれば、即座にそのフォルダ内に表示されることになります。

３つのフォルダシステム

クロノスターは、ファイルをいろいろな視点から検索したり、整理したりできるように性質の異なった３つのフォルダシステムを持っています。ファイルを属性値で整理する前述のクロノスター独自のフォルダシステム２種類と属性値と関係なくWindowsのフォルダのようにファイルを配置できるフォルダシステムが１つ用意されています。
属性値でファイルを管理するフォルダのひとつはシステムフォルダと呼ばれ属性項目ごとに属性値がツリー構造に構成されています。もうひとつは、バーチャルフォルダと呼ばれ、フォルダに属性検索・全文検索などの条件を自由に組み合わせて設定できるようになっています。これらのフォルダシステムは、フォルダをクリックすることで検索が行われ、ファイルはダイナミックな検索の結果として表示されます。
さらに属性値を意識しないWindowsタイプのワークフォルダがあります。ワークフォルダには、属性値とは無関係にファイルを入れて管理することが可能です。

システムフォルダ

システムフォルダは、属性を利用したフォルダシステムです。
システムフォルダは、下図のように属性項目ごとに属性値に対応したフォルダがツリー状に構成されています。それぞれのフォルダはクリックするとその属性値を持ったファイルをサーバから検索して表示します。ツリーの階層を下がっていくとその上位にあるフォルダの条件を引き継いでＡＮＤ条件で検索が行われます。つまり、階層を下がるにつれて検索条件が多く設定されることになり、ファイルが絞り込まれていきます。また、ある階層の条件を設定せずに検索を続けたい場合には、その階層内にクロノスターが設定した特殊フォルダである”選択しない”フォルダをクリックすることで絞込み検索を続けることができます。

下の例では、
  属性グループ＝設計
  ファイル分類＝デザイン
  メディアタイプ＝ＤＶＤ－ＲＡＭ
という属性にマッチしたファイルが表示されることになります。
その下の担当者名のフォルダ（たとえば鈴木）を開くと
  担当者＝鈴木
という条件が上記に追加されて検索されます。

システムフォルダは、ファイルの検索を行うだけでなく、登録にも非常に便利に使うことができます。ファイルをドラッグ＆ドロップしてフォルダに登録するとそのフォルダを開いたときに使用される検索条件が、ファイルの属性として付加されます。大量のファイルに属性値を付けて登録するといった作業をマウス操作だけで簡単に行うことができます。

  1. システムフォルダのツリー構成の設定は、クロノスターのシステム管理ツールで行います。
  2. システムフォルダのトップ（左端）は、属性グループと呼ばれる属性をまとめるためのフォルダとなっています。このフォルダをクリックしてもファイルは表示されません。

バーチャルフォルダ

バーチャルフォルダは、属性を利用したフォルダシステムです。
システムフォルダが、前もってつくられた属性のツリーを使用しているのに対して、バーチャルフォルダは、個々のフォルダに検索条件を自由に設定することができます。システムフォルダと同様にフォルダをクリックして開くことによってサーバに登録されたファイルから、条件にマッチしたファイルが検索されて表示されます。システムフォルダと異なるのは、ひとつのフォルダに対して複雑な検索条件を自由に設定できることです。たとえば、全文検索と属性検索を組み合わせたり、ファイルのタイプや作成日で絞り込んだりといったことがひとつのフォルダで実現できます。

バーチャルフォルダには、共有と個人の２種類があります。共有バーチャルフォルダは、同じクロノスターサーバを使用している全員が見ることができます。グループで、ファイルの整理方法などを話し合って、フォルダを作っていくと良いでしょう。グループ内でのファイルの共有を有効に行うことができます。逆に個人バーチャルフォルダは、使用者のみが読み書きできるようになっています。個人的に検索条件などを記憶させておきたいときは、個人用のバーチャルフォルダを使用すると便利です。
バーチャルフォルダに設定された条件から属性が一意に決定できる場合には、そのバーチャルフォルダを利用して登録を行うこともできます。属性が一意に決定できないために登録に利用できないフォルダはクロノスターにより認識されて、登録に利用できないことを示すフォルダアイコンが表示されます。登録に利用できない条件の例としては、以上や以下を検索条件に設定した場合、全文検索条件を設定した場合等が当てはまります。

バーチャルフォルダは、親フォルダの条件を自動的に引き継ぐことはありません。ツリー構造にしても、それぞれが独立した条件を設定できます。

ワークフォルダ

ワークフォルダは、属性と関係のないWindowsタイプのフォルダシステムです。
フォルダを自由に作成して、その中にファイルを整理しておくことが可能です。ファイルを一時的にまとめておく場合などに利用すると便利です。しかし、ひとつWindowsのフォルダと異なる点は、フォルダ内のファイルは実体ではなく、サーバ内にあるファイルのショートカットのような存在であるということです。つまり、コピーがローカルホストに作られたりするのではなく、あくまでサーバ内に存在するファイルを指し示しているだけです。同一のファイルを複数のフォルダに置くことも可能ですが、あくまで実体はサーバ上にひとつだけ存在しています。

システムフォルダやバーチャルフォルダでは、ファイルの属性が変更されてフォルダの条件とマッチしなくなると自然とそのフォルダにファイルが見えなくなることがあります。その点、ワークフォルダは、属性を変更してもファイルはフォルダを移動して見えなくなることはありません。このような特性を活かして、ファイルに付ける属性が確定していない場合などには、ワークフォルダにファイルをいれておいて、ゆっくりと属性設定をするなどといった使い方ができます。

ワークフォルダにも、バーチャルフォルダと同じように共有と個人の２種類が存在します。ファイルを共有したい場合と個人的に整理したい場合とで使い分けると便利です。


基礎編

2. 基礎編

クロノスターの基本的な使用方法をご紹介します。

    • 2.1 ファイルを登録する
      • - ドラッグ＆ドロップで登録する
      • - 登録ウィンドウを使う
    • 2.2 ファイルの属性の設定と変更
      • - ファイルの属性設定と変更
    • 2.3 ファイルを検索する
      • - フォルダを使って検索する
      • - 全文/属性検索をする
      • - 検索結果を残す
    • 2.4 検索結果を表示する
      • - リスト表示
      • - マルチイメージ表示
      • - ３Ｄ表示
    • 2.5 ファイルの操作
      • - ファイルを開く
      • - ファイルを取り出す
    • 2.6 フォルダの操作
      • - フォルダを作成する
      • - フォルダの名前変更
      • - フォルダのコピー
      • - フォルダの削除


ファイルを登録する

2.1 ファイルを登録する

クライアントPCのハードディスクにあるファイルに属性を付加してサーバに保存する作業を「登録」と呼びます。クロノスターでは簡単な操作で登録を行うことができます。

ドラッグ＆ドロップで登録する

システムフォルダを利用すると、エクスプローラからファイルをドラッグ＆ドロップするだけで、ファイルに属性をつけて登録することができます。

それでは実際のファイルを使ってドラッグ＆ドロップ登録を行ってみましょう。本マニュアルでは”DVD_01.bmp”というファイルを使って説明しますが、お手持ちの適当なファイル名に置き換えて読み進めてください。

1.エクスプローラとクロノスターを起動する

[スタート]メニューから[プログラム]->[ChronoStar]->[ChronoStar 2.0]の順に選択し、クロノスターを起動します。同様にエクスプローラも起動します。ドラッグ＆ドロップによる登録を行う準備として、エクスプローラとクロノスターの両方のウィンドウが見えるようにウィンドウを配置します。

クロノスターを起動すると以下のようなサーバ選択の画面が表示されます。複数のサーバを使い分ける場合は、ここで接続するサーバを選択します。サーバが1台の場合は、”次回起動時も表示”のチェックを外せば、サーバ選択をする必要がなくなります。接続するサーバを選択する必要が生じた場合には、クライアントのオプションで、サーバ選択画面が再び表示されるように設定できます。

ローカルログイン使用時にサーバに接続すると、下図のようなユーザログイン画面が表示されます。ここで、ユーザ名とパスワードを入力し、[OK]ボタンをクリックします。ローカルログインを使用していないときには、ユーザログイン画面は表示されません。

2.登録先のシステムフォルダを選択する

クロノスターを起動すると、システムフォルダが表示されます。表示されるフォルダの内容は環境によってさまざまですが、本マニュアルでは次のように[設計]というフォルダが1つだけ表示されます。
ここでフォルダをマウスでダブルクリックするかフォルダの前にある[+]マークをクリックするとサブフォルダが開きます。システムフォルダではトップフォルダが属性グループ名を表わし、サブフォルダが属性値を表わします。

システムフォルダはファイルに付加された属性値を表わすフォルダですので、下図のフォルダには[設計]という属性グループのデザイン・DVD-RAMという属性値が設定されていることになります。

今回はこのフォルダにファイルを登録します。

トップフォルダには、ファイルをドラッグ＆ドロップで登録することができません。

3.ファイルをドラッグ＆ドロップして登録する

エクスプローラで”DVD_01.bmp”を選択し、マウスの左ボタンを押したままクロノスター上に移動してボタンを離します。ボタンを離す(ドロップする)場所はクロノスターの右側のリスト領域か選択しているツリーの真上です。

ファイルをドロップすると登録が開始され、メインウィンドウのステータスバーに登録状況が表示されます。

登録が完了すると登録完了ダイアログが表示されます。

登録ダイアログを閉じると、ステータスバーが通常表示に戻り、登録されたファイルがリスト表示されます。

4.登録ファイルの属性を確認する

登録されたファイルを選択し、[ファイル]-[属性...]とするとファイルに設定された属性値を表示することができ、下図のようにデザイン・DVD-RAMという属性値が自動的に設定されていることが確認できます。属性表示の詳細は「2.2 ファイルの属性の設定と変更」で説明します。

登録ウィンドウを使う

ドラッグ＆ドロップによる登録では、管理者が事前に設定した固定入力値を持つ属性だけが設定されますが、登録ウィンドウを使用することでその他のあらゆる属性値を登録時に設定することができます。

1.登録メニューを実行する

クロノスターを起動し、[ファイル]-[登録]を選択します。

2.登録ファイルを選択する

[ファイルを開く]ダイアログボックスが開きますので、登録したいファイルを選択します。複数のファイルを選択することもできます。ここでは"DVD_02.bmp"を選択します。

[開く]ボタンをクリックすると登録ウィンドウが開きます。

3.属性グループを追加する

登録ウィンドウが開いた状態では、左側にファイルのサムネイル、右側にはファイルの属性値が表示されています。このまま[登録]ボタンのクリックで登録ができますが、後にファイルを検索しやすくするためにファイルに属性を設定することをお奨めします。

登録ウィンドウの右下にある[属性編集]ボタンをクリックするとポップアップメニューが表示されますので、[属性グループの追加]-[設計]の順に選択します。これで[属性グループ]の欄に[設計]ボタンが追加されました。

書き込み権限がない属性グループを追加することはできません。

4.属性値を入力する

属性グループの欄から[設計]ボタンを選択すると、[設計]属性グループの内容が表示されます。このままではすべてが空欄となるので、[ファイル分類]と[メディアタイプ]の属性値を設定し、登録することにします。

ファイル分類の入力欄をクリックすると、右側にドロップダウンのボタンが表示されます。このボタンをクリックし、表示されたリスト中から<デザイン>を選択して設定します。このように管理者によって事前に属性値が設定されている属性項目は、ドロップダウンから値を選択することができます。同様にして、[メディアタイプ]もドロップダウンから、<DVD-RAM>を選択して設定します。

システムフォルダに表示される属性値はドロップダウンで選択できます。

5.登録を実行する

[ファイル分類]="デザイン",[メディアタイプ]="DVD-RAM"と入力し、[登録]ボタンのクリックで登録を実行します。

6.登録されたことを確認する

登録したファイルには[設計]属性グループが設定されているので、システムフォルダでファイルを表示することができます。下図のように確かに登録されていることが確認できます。属性表示の詳細は「2.2 ファイルの属性の設定と変更」で説明します。

[Shift]キーを押しながらドラッグ＆ドロップすると登録ウィンドウが開き、属性を追加することができます。


ファイルの属性の設定と変更

2.2 ファイルの属性の設定と変更

「1.3 属性について」で説明したように、クロノスターではファイルに属性を付加してサーバに保存します。ここでは、登録されたファイルの属性の表示と編集方法について説明します。

ファイルの属性設定と変更

属性を表示する

システムフォルダで[設計]－>[デザイン]－>[DVD-RAM]を開くと、先ほど登録されたDVD_01.bmpとDVD_02.bmpが表示されます。DVD_01.bmpを選択し、メインメニューから[ファイル]－[属性...]を選択するか、ファイルを右クリックして表示されるポップアップメニューから[属性...]を選択すると属性ウィンドウが開きます。

[ツール]－[オプション]でオプションウィンドウを開き、[全般]タブにある[ダブルクリック時の動作]を[属性表示]に設定しておくと、ファイルをダブルクリックするだけで属性ウィンドウを開くことができます。

属性ウィンドウは左側にファイルのサムネイル（縮小画像）、右側にファイルに設定された属性値が表示されます。右側の部分は”属性パネル”と呼ばれます。属性パネルの上部に[ファイル]・[設計]というボタンが並んでいますが、これがDVD_01.bmpに設定されている属性グループ名です。[ファイル]が選択状態になっていますので、その下のタブには[ファイル]属性が表示されています。

それでは[設計]ボタンをクリックしてみましょう。

[設計]ボタンをクリックすると、その下のタブの内容が[設計]属性に切り替わりました。このように属性パネルでは、選択されている属性グループの内容がタブに表示されるようになっています。

属性を編集する

クロノスターでは登録されたファイルの属性を登録後に変更することができます。DVD_01.bmpはシステムフォルダにドラッグ＆ドロップで登録しましたので、フォルダで指定しなかった属性が空欄になっています。ここでは空欄になっている項目に属性値を設定します。

属性を表示した直後は設定されている属性を誤って変更してしまうことを防ぐために属性が編集できない状態(表示モード)になっています。属性パネルの右上にある　 [編集モード] 　ボタンをクリックすると属性パネルが上に移動し、編集できる状態(編集モード)になります。

編集モードに移行すると、「2.1 ファイルを登録する-登録ウィンドウを使う」での説明と同じ状態になりますので、属性値をドロップダウンや手入力で設定することができます。

編集が完了したら[OK]ボタンをクリックし、編集内容を保存した後、[閉じる]ボタンでウィンドウを閉じます。編集を無効にしたい場合は[OK]ボタンを押さずに[閉じる]ボタンでウィンドウを閉じます。

複数のファイルの属性を扱う

これまでは1つのファイルを選択して属性を表示・編集してきましたが、複数のファイルをまとめて表示・編集することも可能です。メインウィンドウに戻り、DVD_01.bmpとDVD_02.bmpの両方を選択し、属性を表示してください。

属性ウィンドウを開くと1つだけ選択したときには表示されなかったボタンが確認できると思います。左下の数字は現在表示されているファイルを表わし、中央下のボタン群は表示ファイルの切り替えに使用します。 [>] ボタンをクリックすると表示ファイルがDVD_01.bmpからDVD_02.bmpに切り替わります。

複数のファイルを選択しても一度に表示されるファイルは1つなので、属性の編集方法は基本的に同じです。しかし、複数のファイルの属性を効率的に編集するためにクロノスターでは次に説明する機能が用意されています。

属性値の記憶と設定

[<] ボタンをクリックし、DVD_01.bmpを表示します。先ほど設定したようにDVD_01.bmpの属性値はすべて設定されていますが、DVD_02.bmpの属性値はまだ設定されていません。そこで属性値の記憶と設定機能を使ってDVD_01.bmpの属性値をDVD_02.bmpにコピーしてみましょう。

まず、 [編集モード] 　ボタンをクリックし、属性の編集モードにします。次に[属性編集]ボタンをクリックするとポップアップメニューが表示されますので、[表示アイテムの属性セットを記憶]を選択します。

次に [>] ボタンをクリックしてDVD_02.bmpの属性を表示し、同じようにポップアップメニューから[記憶された属性セットを設定]を選択してください。DVD_01.bmpの属性値がDVD_02.bmpにコピーされます。

属性値の串刺し機能

属性値の記憶と設定機能では、すべての属性値がコピーされますので使用できる場合が限られますが、串刺し機能を使うともっと柔軟な属性のコピーができます。

属性の編集モードにしてから、DVD_02.bmpの[担当]を”森”に変更します。すると属性の入力エリアの横に [串刺し] ボタンが表示されますのでマウスでクリックしてください。｢この属性値を他のすべてのオブジェクトに適用します。よろしいですか？｣というメッセージが表示されますので、[はい]を選択します。

[<] ボタンをクリックし、DVD_01.bmpの属性値を表示してください。[担当]が”森”に変更されています。

システムフォルダに設定された属性値にこの串刺し機能を使用すると、ファイルをシステムフォルダ間で移動できます。


ファイルを検索する

2.3 ファイルを検索する

クロノスターに登録されたファイルは簡単な操作で検索することができます。また、検索条件をフォルダと関連付けて記憶し、再利用することもできます。

フォルダを使って検索する

登録時に適切な属性値を設定しておけば、システムフォルダを使ってファイルを検索することができます。

DVD_03.bmpをシステムフォルダで検索します。このファイルには［設計］グループの属性値が設定されているものとします。

  1. システムフォルダを表示して[設計]フォルダの＋をクリックすると、最初の属性候補である[ファイル分類]を表わすフォルダが[設計]フォルダの次の階層に表示されます。フォルダリストの上にある欄に注目してください。”システムフォルダ(設計>ファイル分類)”と表示されています。この欄には、現在選択しているフォルダと次の階層のフォルダの説明が表示されます。

  2. DVD_03.bmpはデザイン資料ですので、[デザイン]フォルダを選択します。ここで初めて<デザイン>という属性値のついたファイルのリストがサーバから検索されて右側のビューに表示されます。このようにシステムフォルダでは2階層目のフォルダからファイルの検索が始まります。
  3. さらに[デザイン]フォルダの＋をクリックして展開すると、次は[メディアタイプ]が表示されます。[DVD-RAM]を選択すると、[デザイン]フォルダでは100件あった検索結果が25件に減ったのがわかります。これは、[設計]グループで<デザイン>という属性値を持ったファイルは100件登録されていたが、<デザイン>かつ<DVD-RAM>という属性値を持ったファイルは25件しかないことを意味します。このようにシステムフォルダではフォルダを展開して階層を下がっていくことで検索条件を絞り込んでいくことができます。

    <デザイン>だけでは、100件のファイルが該当
    100個のオブジェクト

    <デザイン>かつ<DVD-RAM>では、25件のファイルが該当
    25個のオブジェクト

  4. 絞り込んで検索された25件のファイル名を調べると容易にDVD_03.bmpが見つかります。

全文/属性検索をする

システムフォルダを使うと非常に簡単に検索を行うことができますが、その反面、管理者が設定したフォルダによる検索しかできない制限もあります。[検索]メニューを使うと、簡単な操作で非常に柔軟な検索を行うことができます。

属性検索をする

  1. メインメニューから[検索]-[属性検索]を選択するか、メインウィンドウの右上にある [検索] ボタンをクリックします。
  2. 以下の図のようにメインウィンドウが変化し、別のウィンドウが開きます。メインウィンドウの上部にできた領域を「検索パネル」と呼び、新たに開かれたウィンドウを「検索項目選択ウィンドウ」と呼びます。

  3. 検索項目選択ウィンドウは検索項目がツリー状に表示されています。[設計]フォルダを展開し、[メディアタイプ]の下にある[DVD-RAM］を検索パネル上にドラッグ＆ドロップします。

  4. 同様に[担当]の下にある[鈴木]を検索パネルにドラッグ＆ドロップします。
    コントロール（CTRL)キーを押しながら、担当をドラッグ＆ドロップすれば、属性グループ間にまたがって、担当が鈴木であるものを検索することができます。コントロールを押しながらドロップした属性項目名は以下のように黄色で表示されます。

    属性グループ名、サブ属性グループ名をドロップすれば、そのグループまたはサブ属性内の属性項目にまたがって検索できます。
    コントロール（CTRL)キーを押しながら、属性グループ名をドロップすれば、その属性グループのすべての条件が設定されます。同様に、サブ属性グループ名をドロップすれば、そのサブ属性グループのすべての条件が設定されます。
  5. これで検索条件として、「メディアタイプが”DVD-RAM”で担当者が”鈴木”のファイル」という検索条件が設定されました。

  6. [検索実行]ボタンをクリックすると、メインのビューに検索結果が表示されます。検索条件の設定によっては、属性値が一意的ではなく検索結果フォルダに赤いロックアイコンが表示される場合があります。バーチャルフォルダに赤色ロックマークが表示されている場合には、そのバーチャルフォルダに対して新たにファイルを登録することはできません。

    検索条件で、OR条件、～以上、不一致など属性値が一意的でない場合、バーチャルフォルダに新たにファイルを登録できません。そのため、そのバーチャルフォルダに赤いロックアイコンが表示されます。

全文検索をする

マイクロソフトのWordファイルなどの文書ファイルは、ファイルの本文に含まれる文字を全文検索と呼ばれる検索で探し出すことができます。全文検索を使うと、文章の内容を覚えていればファイルを検索することができます。

  1. メインメニューから[検索]-[全文検索]を選択するか、Ctrl+Fキーを押します。
  2. 1行分の検索パネルが表示され、[全文検索][一致]が自動的に設定されます。
  3. 入力エリアに文章中から検索したいキーワード（たとえば”鈴木”）を入力し、[検索実行]ボタンをクリックします。

検索結果を残す

検索を実行すると、バーチャルフォルダの[個人バーチャル]の下に［検索結果］という名前のフォルダが自動的に作成されます。どのような検索条件が設定されているかわかりやすいように、フォルダの名前を変更しておきましょう。

  1. 先ほどの検索で作成された［検索結果］フォルダを開きます。
  2. [検索結果]フォルダをマウスでクリックします。

  3. フォルダ名が編集可能な状態になりますので、”鈴木の作成したDVDデザイン”に変更します。

  4. フォルダ以外の場所をクリックして名前の編集を終了します。

    これでフォルダ名を見るだけで検索条件が想像できるようになりました。また、このフォルダをクリックして開くことでいつでも同じ検索が実行され、最新の状況での検索結果を表示することが可能となります。

    オプションで［終了時に検索結果を削除］をチェックしていると、名前を変更しなかったフォルダはクロノスター終了時に自動的に削除されます。
    すでに作成されているバーチャルフォルダの検索条件を変更する場合は、バーチャルフォルダを選択した後、右ボタンをクリックし、メニューから「検索条件表示」を選択します。検索パネルで条件を変更後、［条件設定］ボタンをクリックしてください。


検索結果を表示する

2.4 検索結果を表示する

検索結果（フォルダの内容）はメインウィンドウの右側のビュー領域に表示されます。クロノスターでは検索結果を次のように様々な方法で表示することができます。

リスト表示
文字でファイルの情報を表示します。
マルチイメージ表示
ファイルのサムネイル画像を表示します。
３Ｄ表示
スライダ表示では、サムネイル画像を３次元空間に配置して表示します。
ブック表示では、サムネイル画像を本の形で表示します。

各表示の切り替えは、［表示］メニューで、-［リスト表示］、-［マルチイメージ表示］または-［３Ｄ表示］を選択してください。

リスト表示

メニューから[表示]-[詳細]を選択すると、検索結果がエクスプローラと同じようにリスト状に表示されます。
・システムフォルダでは標準の状態では、ファイル名とファイル属性が表示されます。
・バーチャルフォルダの場合は、関連する属性値がリストに表示されます。[表示]-[表示項目のカスタマイズ]を選択すると表示項目を変更できます。
・ワークフォルダではファイル名とファイル属性が表示されます。

ファイルの選択やスクロールの操作方法はエクスプローラと同じです。

表示項目のカスタマイズ

メニューから[表示]-[表示項目のカスタマイズ]を選択すると、バーチャルフォルダでリスト表示される項目をカスタマイズすることができます。また、”この設定をシステムフォルダでも有効にする。”をチェックするとシステムフォルダのリスト表示も選択された項目になります。

マルチイメージ表示

メニューから[表示]-[マルチイメージ]を選択すると、検索結果をサムネイルで一覧表示します。ここで表示されるサムネイルは登録時に自動的に生成されます。

操作方法はリスト表示と同じです。

３Ｄ表示

メニューから[表示]-[スライダ]または[表示]-[ブック]を選択すると、検索結果を三次元表示します。スライダ表示はサムネイルをドラム状に並べた表示で、ブック表示はサムネイルを本のページに貼り付けたような表示です。

スライダ表示

ブック表示

３D固有の操作

３D表示モードの場合、３D表示の下部に３D操作コントローラが配置されます。

[表示段数]
スライダ表示では高さ方向にいくつのサムネイルを表示するか、ブック表示ではページごとのサムネイル表示枚数を設定します。
[表示速度]
スライダ表示では回転速度、ブック表示ではページのめくれる速度を設定します。
[>] ボタン
このボタンをクリックすると、自動ページめくりを行います。自動ページめくりの動作中はボタンが [■] 変わります。
スクロールバー
ページめくりを行います。通常のスクロールバーと同じ動作です。

また、スライダ表示では一度に表示されるサムネイル数をオプションで制限できます。一度に表示されるサムネイル数を超えて表示を行う場合、画面の切り替えが行われます。この情報はメインウィンドウのステータスバーの右端に[グループ数]として表示されています。

WindowsNTでは３D表示のメニューは表示されません。


ファイルの操作

2.5 ファイルの操作

検索で見つかったファイルは自由に再利用することができます。ここでは簡単な操作について説明します。

ファイルを開く

システムフォルダで[設計]->[デザイン]->[DVD-RAM]を選択します。DVD_01.bmpを選択してメニューから[ファイル]-[開く]を選択すると、DVD_01.bmpが開きます。

ファイルを開く操作は複数のファイルに対しても実行できます。

開くコマンドでは、エクスプローラ上でファイルを開いたときと同じ操作が行われます。エクスプローラで開けないファイルはクロノスターでも開くことはできません。
[ツール]－[オプション]でオプションウィンドウを開き、[全般]タブにある[ダブルクリック時の動作]を[開く]に設定しておくと、ファイルをダブルクリックするだけでファイルを開くことができます。

ファイルを取り出す

ファイルを取り出す場合も基本的にファイルを開く動作と同じです。DVD_01.bmpを選択して、メニューから[ファイル]-[取り出し]を選択します。[フォルダの参照]ダイアログが表示されますので、ファイルを取り出したいフォルダを選択して[OK]をクリックしてください。


フォルダの操作

2.6 フォルダの操作

クロノスターの３つのフォルダを利用すると、ファイルの検索や整理が容易になります。この章では、フォルダの基本的な操作について説明します。なお、フォルダの活用方法については「3.3 フォルダでファイルを整理する」を参照してください。

フォルダを作成する

バーチャルフォルダとワークフォルダは、エクスプローラのフォルダと同じような感覚で、フォルダを階層的に作成することができます。

バーチャルフォルダを作成する

「2.3 ファイルを検索する」で説明したように、クロノスターで検索した検索条件は、バーチャルフォルダとして残しておくことで同じ条件で何度でも検索を行うことができます。この検索条件の設定は、フォルダの新規作成という形で事前に行うことができます。

  1. [個人バーチャル]を選択してマウスの右クリックし、[フォルダの新規作成]を選択します

  2. フォルダが追加されてフォルダ名が編集可能な状態になっています。フォルダ名にはあとで分かりやすいように検索条件を表す名前を付けるといいでしょう。ここでは「DVD-RAMファイル」と設定します。

  3. フォルダ追加と同時に検索パネルが開いていますので、検索を実行する要領で検索条件を検索パネルにドロップして設定します。ここでは[設計]-[メディアタイプ]-[DVD-RAM]をドロップします。
  4. 検索パネル右上の[条件設定]ボタンをクリックしてバーチャルフォルダの作成を完了します

これで、次回から[DVD-RAM]フォルダをクリックするだけで[設計]属性グループの[メディアタイプ]="DVD-RAM"が設定されたファイルを検索できます。

また、[共有バーチャル]の下にフォルダを追加した場合は、クロノスターを使用している他のユーザにも使用できるフォルダとして追加されます。従って、グループで共有したい情報を検索するフォルダは[共有バーチャル]の下に作成するとよいでしょう。

ワークフォルダを作成する

ワークフォルダはエクスプローラのフォルダと同じ感覚で利用できるフォルダです。

  1. [表示]-[フォルダ]-[ワークフォルダ]を選択するか、メインウィンドウの左側にある[ワークフォルダ]のアイコンをクリックするとワークフォルダが表示されます。
  2. [個人ワーク]を右クリックしてメニューから[新規作成]-[フォルダ]を選択します。

  3. [個人ワーク]の下に[新しいフォルダ]が作成され、フォルダ名が編集可能な状態になっています。自由な名前を入力してリターンキーを押します。
  4. ワークフォルダを作成した後はエクスプローラからドラッグ＆ドロップで登録したり、[ワークフォルダに送る]コマンドで登録済みのファイルをワークフォルダに追加したりすることができます。

フォルダの名前変更

ファイル名と同様、フォルダの名前も自由に変更することができます。

  1. 名前を変更したいフォルダを選択します。
  2. メニューから[ファイル]-[名前変更]を選択します。
  3. 変更したい名前を入力します。
  4. リターンキーを押して変更を確定します。

ただし、以下のフォルダの名前は変更できません。

  • 全てのシステムフォルダ
  • [個人バーチャル]フォルダ・[共有バーチャル]フォルダ
  • [個人ワーク]フォルダ・[共有ワーク]フォルダ
  • [Work Area]フォルダ

フォルダのコピー

フォルダのコピー、ペーストができます。

  1. コピーしたいフォルダを選択します
  2. マウスの右ボタンをクリックし、メニューから[コピー]または[コピー(サブフォルダを含む)]を選択します
  3. コピー先のフォルダを選択します
  4. マウスの右ボタンをクリックし、メニューから[貼り付け]を選択します

ただし、以下のフォルダのコピー、ペーストはできません。

  • 全てのワークフォルダ
  • [Work Area]フォルダ

フォルダの削除

フォルダが不要になった場合は、エクスプローラと同じようにフォルダを削除する事ができます。

  1. 削除したいフォルダを選択して右クリックし、ポップアップメニューから［フォルダの削除］を選択します

  2. 「削除の確認」ダイアログが出ますので、［はい］を選択します

ただし、以下のフォルダは削除できません

  • 全てのシステムフォルダ
  • [個人バーチャル]フォルダ・[共有バーチャル]フォルダ
  • [個人ワーク]フォルダ・[共有ワーク]フォルダ
  • [Work Area]フォルダ
フォルダを削除しても、フォルダに含まれるファイルは削除されません


応用編

3. 応用編

クロノスターをより高度に使いこなすための方法をご説明します。

  • 3.1 登録
    • - 属性値を付けずに登録
    • - 複数のファイルを登録
    • - 動画の登録
  • 3.2 ファイルの操作
    • - ファイルの移動
    • - ファイルの削除
    • - ファイル名の変更
    • - ファイルのフォーマット変換
  • 3.3 フォルダでファイルを整理する
    • - バーチャルフォルダで整理する
    • - ファイルをワークフォルダに送って整理する
    3.4 ファイルのリンク
    • - ファイル間のリンクを作成
    • - ファイルのリンク表示
    • - ファイルのリンク削除
  • 3.5 チェックイン・チェックアウト
    • - ファイルのチェックアウト
    • - ファイルのチェックイン
    • - 来歴管理
  • 3.6 印刷
    • - ファイルを印刷する
  • 3.7 承認
    • - 承認の依頼
    • - 承認
  • 3.8 一括転送
    • - メディアグループ
    • - メディアグループへの転送
    • - 転送予約のキャンセル
  • 3.9 CSV出力
    • - ファイル属性のCSV出力
  • 3.10 メール通知
    • - メール通知設定
    • - メール通知一覧
  • 3.11 メール登録
    • - メールテキストを登録する
    • - 添付ファイルを登録する
    • - タグ一覧
  • 3.12 サムネイル変更
    • - サムネイル変更
  • 3.13 ファイルのインポート/エクスポート
    • - ファイルのインポート/エクスポート
  • 3.14 操作履歴
    • - 操作履歴
  • 3.15 権限設定
    • - 権限設定
  • 3.16 オプション設定
    • - [全般]タブ
    • - [検索]タブ
    • - [３Ｄ表示]タブ
    • - [パスワード]タブ
    • - [最適配置]タブ
  • 3.17 ＴＩＰＳ --知っていると便利--
    • - 操作
    • - 運用


登録

3.1登録

一般的な登録の方法については「2.1 ファイルを登録する」ですでに説明しましたが、ここでは状況に応じた効率的な登録方法について説明します。

属性値を付けずに登録

登録したファイルを効率的に検索できるように、登録時に属性をつけることが望ましいということは前の章で説明しましたが、登録時点で適当な属性が決まっていない場合や属性をつけている時間が無い場合など、とりあえず登録だけしたいという状況は比較的多いと思います。

このような場合、ワークフォルダにドラッグ&ドロップで登録しておき、後で属性編集によって属性をつけるという運用をお薦めします。

ワークフォルダに登録する

  1. メニューから[表示]-[フォルダ]-[ワークフォルダ]を選択し、ワークフォルダを開きます
  2. [個人ワーク]をマウスで右クリックしてポップアップメニューから[フォルダの新規作成]を選択します
  3. 適当な名前をつけます
  4. エクスプローラから登録したいファイルを選択し、ワークフォルダにドラッグ&ドロップして登録します

属性を編集する

  1. ファイルを登録したワークフォルダを開きます
  2. ファイルを選択してマウスで右クリックし、ポップアップメニューから[属性]を選択します
  3. 「2.2 ファイルの属性の設定と変更」で説明した手順で属性を設定します

複数のファイルを登録

エクスプローラで複数のファイルを選択してドラッグ&ドロップすることで、ファイルをまとめて登録することができます。以下にファイルをまとめて登録する場合に便利な属性の設定方法について説明します。

  • すべて同じ固定入力値の場合
  • すべて同じ属性値の場合（手入力含む）
  • 固定入力値はすべて同じで、手入力する属性値が異なる場合

すべて同じ固定入力値の場合

すべて同じ固定入力値の場合、システムフォルダにまとめてドラッグ＆ドロップするとよいでしょう。

  1. エクスプローラで登録したい複数のファイルを選択します
  2. クロノスターのシステムフォルダを展開し、設定したい属性値を持つフォルダを表示します
  3. エクスプローラからファイルをドラッグ＆ドロップで登録します

すべて同じ属性値の場合（手入力含む）

手入力を含む属性値をまとめて設定する場合、登録専用クライアントを使用すると便利です。

  1. ［スタート］－［プログラム］－［ChronoStar］－［登録］の順に選択します

  2. 登録ファイルをドラッグ＆ドロップする前に、［属性編集］ボタンをクリックして、［属性グループの追加］-［設計］を選択します
  3. 全ての登録ファイルに設定したい属性値を入力します
  4. 登録ウィンドウの「ファイルをドロップして下さい」と書かれた部分へエクスプローラからファイルをドラッグ＆ドロップします。ドロップされたファイルに上記手順で追加された属性値が自動的に追加されたのが確認できます
  5. ［一括登録］ボタンをクリックして登録を実行します
登録専用クライアントでは、規定値という概念があります。登録専用クライアントを起動した直後の画面では[登録アイテム名]の欄に”デフォルト値”と表示されています。この状態で属性値を設定すると、設定した属性値が規定値となって、以降登録アイテムにファイルが追加されると、自動的に設定した規定値が追加されます。また、[属性編集]メニューから[表示アイテムの属性セットを記憶]コマンドを選択することで、表示されているアイテムに設定されている属性値を規定値とすることができます。

固定入力値はすべて同じで、手入力する属性値が異なる場合

固定入力値は同じだが、ファイルごとに異なる手入力の属性値を追加して登録したい場合、次のようにすると便利です。

  1. エクスプローラで登録したい複数のファイルを選択します
  2. クロノスターのシステムフォルダを展開し、設定したい属性値を持つフォルダを表示します
  3. [Shift]キーを押しながらエクスプローラからファイルをドラッグ＆ドロップします
  4. 登録ウィンドウが開きますので、手入力したい属性値を設定します
  5. ［登録］ボタンをクリックして表示されているファイルを登録します
  6. 4,5の手順を繰り返して全てのファイルを登録します

その他にも「2.2 ファイルの属性の設定と変更」で説明した手順で登録時の属性値を編集できます。

複数属性の登録

クロノスターでは、「 1.3 属性について」で説明しましたように、さまざまな属性を付加することができます。
属性の追加、変更は属性変更画面で行います。

  1. 変更したいファイルを選択します。
  2. メニューの「ファイル」「属性」を選択し、属性表示画面を開きます。
  3. 編集ボタン（えんぴつアイコン）を押して、属性編集モードに移行します。
  4. 属性グループの追加を押し、属性グループを追加します。

ここで、属性グループの追加の同一属性グループ名を選択します。

区別するため属性グループ名の後ろに連番が追加されます。

動画の登録

クロノスターではファイルの登録時にサムネイルを自動的に生成しますが、AVIファイル、MPEGファイルの登録の際にはマルチサムネイルと呼ばれるサムネイルも同時に生成して登録します。

  1. エクスプローラでAVIファイルまたはMPEGファイルを選択してシステムフォルダにドロップします
  2. 登録されたファイルを選択してメニューから[ファイル]－[属性...]を選択します
  3. 登録時にマルチサムネイルが生成されているので、サムネイルの下にシークバーが現れます

  4. シークバーを操作すると、パラパラとサムネイルが切り替わります
AVIファイルやMPEGファイルのマルチサムネイルを生成するには、クライアントのインストールのカスタムセットアップで「AVIサムネイル取得」や「MPGサムネイル取得」のアドインをインストールする必要があります。詳しくは、「セットアップガイド」をご覧ください。


ファイルの操作

3.2 ファイルの操作

ファイルの移動

クロノスターのフォルダはファイルシステム上の保存場所とは無関係なため、一般的なファイルの移動という概念はありません。しかしながら、属性を操作することによって見かけ上のファイルの移動を行うことができます。

  1. システムフォルダで[設計]->[デザイン]->[DVD-RAM]を開きます
  2. DVD_01.bmpを選択し、メニューから[ファイル]－[属性...]を選択して属性を表示します
  3. [編集モードアイコン] をクリックして編集モードに移行します
  4. [メディアタイプ]を"DVD-RAM"から"MO"に変更します
  5. [OK]をクリックして状態を更新し、[閉じる]でウィンドウを閉じます
  6. [DVD-RAM]フォルダから"DVD_01.bmp"が消えて[MO]フォルダに現れたのが確認できます

ファイルの削除

クロノスターに登録されたファイルはエクスプローラと同じ感覚で削除することができます。

  1. 削除したいファイルを選択します
  2. メニューから[ファイル]－[削除]を選択します
  3. [ファイルの削除の確認]ダイアログで[はい]を選択します。

ワークフォルダには表示しないが、実ファイルは削除したくない場合には、[ファイル]-[送る]-[ワークフォルダから外す]を実行します。

チェックアウト中のファイルなど、特別な状態になっているファイルは削除できないことがあります。

ファイル名の変更

ファイル名の変更もエクスプローラと同じ感覚で行えます。

  1. 名前を変更したいファイルを選択します
  2. メニューから[ファイル]－[名前変更]を選択します
  3. ファイル名が編集可能な状態になっていますので、変更したい名前を入力します
  4. [リターン]キーを押して変更を確定します
無効なファイル名を入力した場合はエラーメッセージが表示されて変更がキャンセルされます。

ファイルのフォーマット変換

[ファイルフォーマット変換]コマンドで登録されたファイルのフォーマットを別のフォーマットに変換することができます。

  1. "DVD_01.bmp"を選択します
  2. メニューから[ツール]－[ファイルフォーマット変換...]を選択します
  3. [ファイル変換先選択]ウィドウが開きますので、"JPEGファイル"を選択して[コンバート開始]ボタンをクリックします

この機能は次のように使うことができます。

  • ファイルを作成したアプリケーションがバージョンアップする場合にフォーマットを最新にしておくことで、長期に渡ってデータの閲覧を保証する
  • ファイル作成には使い慣れたアプリケーションを用い、ファイルが完成したらグループの誰もが持っているアプリケーションで閲覧できるフォーマットに変換することでデータを共有する
ワープロファイルからイメージファイルのような異なる種類のフォーマット変換はできません。


フォルダでファイルを整理する

3.3 フォルダでファイルを整理する

バーチャルフォルダやワークフォルダを利用するとファイルをさまざまな視点から整理して管理することができます。たとえば、簡単なタスク管理やプロジェクト管理も可能となります。この章では、ファイル整理の方法をいくつか具体的にご紹介します。

バーチャルフォルダで整理する

バーチャルフォルダのフォルダごとに検索条件が設定できるという特長を活かすと以下のようなフォルダが簡単に作成できます。

  • 最近アクセスしたファイルを集めるフォルダ
    最終アクセス日が１ヶ月以内のファイルを検索します。

    ("%DATEm-1%"は、現在の日付から一ヶ月前を表します）

  • 関心のあるファイルを定期的にチェックするフォルダ
    特定のキーワード（たとえば、「プラント設計」）を含むファイルを検索します。

  • 自分が作成担当する未完成ファイルのフォルダ
    担当者が自分自身（浅野）で進捗状況が100%に達していないファイルを検索します。

バーチャルフォルダを利用すると、ファイルの状態を動的に管理することが可能になります。最後の例のようにプロジェクトを管理するといった目的に使用することも可能です。その他にもアイデア次第でさまざまな活用が考えられます。

バーチャルフォルダの作成例

では、前述の「自分が作成担当する未完成ファイル」を検索するためのバーチャルフォルダを作成してみます。
ここでは管理者によって次に示す[プロジェクト]属性グループが設定されていることを前提に説明します。ご使用中のシステムに、同じ属性グループがない場合は、この例を参考にご自身のシステムに応用してください。

属性グループ | サブ属性 | 属性項目
プロジェクト | 全般 | プロジェクト名
担当者
進捗(%)
締め切り
  1. [表示]-[フォルダ]-[バーチャルフォルダ]を選択するか、メインウィンドウの左側にある[バーチャルフォルダ]のアイコンをクリックするとバーチャルフォルダが表示されます。
  2. [個人バーチャルフォルダ]を右クリックしてメニューから[新規作成]-[フォルダ]を選択します。

  3. [個人バーチャル]の下に[新しいフォルダ]が作成され、名前が変更可能な状態になっています。同時にメインウィンドウが変化し、別のウィンドウが開きます。メインウィンドウの上部にできた領域を「検索パネル」と呼び、新たに開かれたウィンドウを「検索項目選択ウィンドウ」と呼びます。フォルダ名を"担当する未完成ファイル"と入力します。以下は、属性検索と同じ手順となります。
  4. 検索項目選択ウィンドウは検索項目がツリー状に表示されています。[プロジェクト]-[全般]と順にフォルダを展開し、その下にある[担当者］と[進捗(%)]をそれぞれ検索パネル上にドラッグ＆ドロップします。

  5. ドロップダウンから[担当者]に“浅野”を選択して入力し、[進捗(%)]にはキーボードから"100"という数値を入力します。次に[進捗(%)]の検索条件をドロップダウンから”未満”に設定します。

  6. [条件設定] ボタンをクリックして、条件をフォルダに設定します。同時に検索が実行され、検索結果が表示されます。
  7. [検索アイコン] ボタンをクリックして終了します。
  8. 以上で「自分が作成担当する未完成ファイル」を検索するためのバーチャルフォルダの作成が終了します。以降は、このフォルダをクリックするだけで同条件での検索が実行されます。

ファイルをワークフォルダに送って整理する

ワークフォルダはバーチャルフォルダとは対照的に静的な管理をするのに適しています。ワークフォルダにはサーバに登録されているファイルを属性に関係なく自由に整理することができます。なお、[個人ワーク]は使用者のみが参照でき、[共有ワーク]は同じクロノスターサーバを使用する全員が参照できるようになっています。個人的にファイルを整理したい場合は、[個人ワーク]を使用し、グループ内でのファイルを共有しつつ整理したい場合は、[共有ワーク]を使用するとよいでしょう。

たとえば、以下のような使い方が考えられます。

  • 自分が担当するプロジェクトのファイルを集めておく
    [個人ワーク]に自分が担当するプロジェクトのフォルダを作成して、属性が異なるが関連のあるファイルを集めて整理します。

  • 会議に必要なファイルを一時的にグルーピングする
    [共有ワーク]に会議の資料を集めるためのフォルダを用意して、会議参加者に会議で使用する資料の登録や資料を事前に検討するように指示する。

ワークフォルダを作成し、ファイルを送る

ここでは、担当するプロジェクトのファイルを保持するフォルダを作り、ファイルをフォルダに入れるまでの手続きをご紹介します。

  1. [表示]-[フォルダ]-[ワークフォルダ]を選択するか、メインウィンドウの左側にある[ワークフォルダ]のアイコンをクリックするとワークフォルダが表示されます。
  2. [個人ワーク]を右クリックしてメニューから[新規作成]-[フォルダ]を選択します。

  3. [個人ワーク]の下に[新しいフォルダ]が作成され、名前を変更するモードになっています。例として"DVD-RAMプロジェクト"という名前を付けることにします。
  4. システムフォルダやバーチャルフォルダまたは検索機能などを使って、このフォルダに登録したいファイルをサーバから検索します。ここでは、DVD_03.bmpをフォルダに入れることにします。
  5. 検索結果のリストからDVD_03.bmpを選択し、メニューから[ファイル]-[送る]-[ワークフォルダに送る...]を選択すると[ワークフォルダに送る]ウィンドウが開きます。選択したファイルを右クリックし、ポップアップメニューから[送る]-[ワークフォルダに送る...]を選択しても同じです。

  6. [ワークフォルダに送る]ウィンドウで[参照...]ボタンをクリックします。
  7. [フォルダの参照]ダイアログでツリーから[DVD-RAMプロジェクト]を選択して[OK]ボタンをクリックします。

  8. [ワークフォルダに送る]ウィンドウの[送り先]に「個人ワーク(User名)\DVD-RAMプロジェクト」が設定されたのを確認して[OK]ボタンをクリックします。（この例ではUser名 "asano" で Windows にログインして操作していますので、"asano"が表示されています。）
  9. ワークフォルダで[個人ワーク]->[DVD-RAMプロジェクト]を開くと、DVD_03.bmpが追加されていることが確認できます。

以上の要領でプロジェクトに関連するファイルをワークフォルダに追加しておけばファイルの属性値に関わらずいつでも目的のファイルを見つけ出すことができます。

ワークフォルダにファイルを送っても、実体が移動するわけではありません。単にファイルのショートカットのようなものがワークフォルダ内に作成されるに過ぎません。システムやバーチャルフォルダには影響はありません。

ワークエリア

ワークフォルダのファイルを一時的に集めておくフォルダと位置づけた場合、フォルダに含まれるファイルにはできるだけ簡単な操作でアクセスできるほうが便利です。クロノスターではワークエリアと呼ばれる特別なワークフォルダを設け、そのフォルダの内容は常にメインウィンドウに表示するようになっています。

実際にはワークエリアは[個人ワーク]フォルダの下にある[Work Area]フォルダで、この中身が常にメインウィンドウに表示されているということになります。ワークエリアを利用するメリットは以下の通りです。

  1. 起動直後にD&D登録ができる
  2. 起動直後にファイルを選択できる


ファイルのリンク

3.4 ファイルのリンク

クロノスターでは登録したファイル間にリンクと呼ばれる親子関係を設定することができます。

リンクを設定すると、親から子、子から親を高速に検索することができます。

ファイル間のリンクを作成

リンクには親子関係があり、リンクの親をリンク元、リンクの子をリンク先と呼びます。次の手順でファイル間のリンクを作成します。

  1. リンク元にしたいファイルを１つまたは複数選択し、メニューから[ツール]－[リンク]－[リンク元登録...]の順に選択します
  2. リンク先にしたいファイルを１つまたは複数選択し、メニューから[ツール]－[リンク]－[リンク先登録...]の順に選択します
  3. リンクに先とリンク元の関係を示すコメントをリンクにつけるには、[リンク先はリンク元にとって]および[リンク元はリンク先にとって]をコンボボックスから選択するか手入力します

  4. [OK]をクリックしてリンクを作成します
  5. リンクが作成されると、リンク元のファイルのアイコンが変化します

ファイルのリンク表示

ファイルを選択してリンクを表示する方法は大きく分けて２つあります。

リンク表示でビジュアルに表示する

  1. 「リンクを作成」でリンク元にしたファイルを１つ選択し、［ツール］－［リンク］－［リンク表示］－［下へ］（またはその他の項目）を選択します
  2. [ChronoStarリンクビュー]ウィンドウが開き、選択したファイルから関連ファイルへのリンクがビジュアルに表示されます。

・CTRLを押しながらリストボックスのタイトル部分をドラッグすれば、それにつらなるリストボックスを一括移動できます。
・CTRLを押しながらリストボックスの右上部のXアイコンをクリックすれば、それにつらなるリストボックスを一括して閉じることができます。
・リストビューの端を超えて、リストボックスを移動させたい場合には、リストボックスをドラッグしてリストビューの端に到達した時にSHIFTキーを押してしばらくまてばスクロールします。

上位リンク検索でリスト表示する

  1. 「リンクを作成」でリンク先に設定したファイルを１つ選択し、［ツール］－［リンク］－［上位リンク検索］－［上位］（または［最上位］）を選択します
  2. [リンク検索]ウィンドウが開いて、リンクファイルがリスト表示されます

  3. 必要に応じて、このダイアログのメニューからファイル出力や印刷を選択して実行します

ファイルのリンク削除

リンクの削除は[ChronoStarリンクビュー]ウィンドウで行います。

  1. リンクをリンクビューで表示します
  2. リンクを削除したいファイルを選択してマウスの右クリックをします
  3. ポップアップメニューから［リンク削除］を選択します

コメントの変更

リンクのコメント変更は[ChronoStarリンクビュー]ウィンドウで行います。

  1. リンクをリンクビューで表示します。
  2. コメントを変更したいファイルを選択してマウスの右クリックをします
  3. ポップアップメニューから[コメント変更]を選択します。


チェックイン・チェックアウト

3.5 チェックイン・チェックアウト

クロノスターはグループでファイルを管理するためのシステムですので、登録されたファイルの編集には排他制御を行います。

ファイルのチェックアウト

登録されたファイルを編集するときは、「チェックアウト」と呼ばれる操作によってファイルをローカルに取り出して編集を行います。チェックアウト中のファイルはサーバ上で特別な扱いとなり、削除や別の人による編集ができないようになります。

  1. 編集したいファイルを選択します
  2. メニューから[ファイル]－[チェックアウト/チェックイン]－[チェックアウト]を選択します
  3. ［チェックアウト］ダイアログが開きます

  4. ［コメント］の欄にチェックアウトの理由や編集内容、［チェックアウト先］の欄にファイルを取り出すローカルパスを指定します
  5. チェックアウト後すぐに編集に取り掛かる場合には［関連付けられたアプリケーションで開く］チェックボックスをチェックします
  6. 複数ファイルを同時にチェックアウトする時に、[ファイル毎に個別の内容を設定する]をチェックすると、ファイル毎に設定を変更できます。
  7. ［OK］をクリックするとファイルがチェックアウトされます
  8. メインのリストでチェックアウトしたファイルは自動的にアイコンが変化します

    ファイルのフォーマット変換（TIF->CAD、BMP->JPG等）などの場合に、ファイルを置換することが可能です。拡張子を除くファイル名は同一でなければなりません。
    ただし、システム管理ツールで設定が必要になります。

ファイルのチェックイン

ファイルの編集が終わったら、「チェックイン」と呼ばれる操作によってサーバ上のファイルを更新します。

  1. チェックインしたいファイルを選択して、メニューから［ファイル］－［チェックアウト/チェックイン］－［チェックイン］を選択します
  2. [チェックイン]ウィンドウが開きますので、必要ならば属性値を修正して［チェックイン］ボタンをクリックします

高速チェックイン

サムネイルを取り直す必要がない場合は、[ツール]－[チェックアウト状況]を選択して、このダイアログの[ファイル]－[高速チェックイン]を選択してサムネイル生成を省略することで高速にチェックインすることができます。

来歴管理

ファイルをチェックアウトする際、[改訂する]というチェックをしている場合、ファイルのチェックアウト時にファイルのバージョンが更新されます。

ファイルを改訂する

  1. 改訂したいファイルを選択します
  2. メニューから[ファイル]－[チェックアウト/チェックイン]－[チェックアウト]を選択します
  3. ［チェックアウト］ダイアログで、［改訂する］チェックボックスを有効にします
  4. [改訂理由]と[改訂内容]の欄に適当な内容を記述し、［OK］をクリックします
  5. ファイルを編集します
  6. ファイルの編集が完了したら、ファイルを選択してチェックインします
  7. 自動的にファイルが改訂されます
  • 記述した改訂内容と改訂理由は[履歴表示]ウィンドウで表示されます。
  • [チェックアウト取り消し]コマンドを実行すると、バージョンは元に戻ります。

ファイルの履歴を表示する

  1. 過去に改訂されているファイルを選択して［ツール］-［履歴表示］を選択します
  2. ［履歴表示］ウィンドウが開きます

履歴ファイルに対して属性表示や印刷などの操作をすることができます。

ロールバック。ひとつ前のバージョンに戻すことができます。ただし一度ロールバックしたものは元に戻せません。

改訂理由・内容変更。チェックアウト時入力した改訂理由・内容を変更できます。


印刷

3.6 印刷

ファイルを印刷する

クロノスターの印刷機能はエクスプローラと同等です。

  1. 印刷したいファイルを１つまたは複数選択します
  2. メニューから[ファイル]－[印刷]を選択します
  3. [プリンタの設定]ダイアログが開きますので、[プリンタ名]で印刷するプリンタを選択し、必要なら[用紙]や[印刷の向き]を設定します
  4. [OK]をクリックすると印刷が開始されます


承認依頼

3.7 承認

クロノスターに登録したファイルはメールとWEBを組み合わせてオンラインによる承認作業を行うことができます。

承認の依頼

クロノスターではあらかじめ管理者によって設定された承認ルートを選択するだけで簡単に承認を依頼することができます。

  1. 承認してもらうファイルを選択します
  2. メニューから［ツール］-［承認依頼...］を選択します

  3. [承認依頼]ウィンドウで［承認ルート］を選択し、［承認表題］を入力します
  4. 連絡事項がある場合には[承認者への連絡事項]を入力します。
  5. ［開始］をクリックして承認を依頼します

承認

［承認依頼］が実行されたファイルを承認・却下するには、ふたつの方法があります。ひとつはクロノスタークライアントのメニューから行う方法です。もうひとつの方法は、メールとWEBを使用する方法です。これらの方法を順番に説明します。

クロノスタークライアントを利用した承認

  1. メニューから［ツール］-［承認状況...］を選択します

このウィンドウでは様々な設定を行い、更新ボタンをクリックすることで、望みのリストを表示できます。
・自分の開始した承認をリストしたい場合は、”自己開始分”をチェックします。
・自分が承認者になっているものをリストしたい場合には、”自己担当分”をチェックします。
・承認済みのものをリストする場合には、承認日をチェックして、開始日と終了日を設定します。
・ある決められた種類のファイルだけをリストする場合には、ファイル種類から希望の拡張子を選択します。

表示されたリストからファイルを選択して、以下のコマンドを[ファイル]メニューから実行できます。
・承認：　選択されたファイルを承認します。
・差し戻し：　選択されたファイルを却下します。
・スキップ：　選択されたファイルを次の人にまわします。
・削除：　自己開始分の承認を取り消します。
・開く：　選択されたファイルを開きます。
・印刷：　選択されたファイルを印刷します。
・CSV出力：　表示されているリストをCSV出力します。出力先は、オプション設定した一時ディレクトリーです。

メールとWEBを利用する承認

承認依頼がされると自動的にメールが承認者に送られます。承認者は以下のようなメールを受け取ります。

メールの中に記述されたWEBへのリンクをクリックすると、以下のようなWEBページが開きます。コメントを記入して承認ボタンをクリックすれば、次の人に承認依頼のメールが送られます。


一括転送

3.8 一括転送

DVDオートチェンジャなどのリムーバブルメディアを組み込んだシステムの場合、登録ファイルをリムーバブルメディアに転送して保管することが出来ます。

メディアグループ

概念

クロノスターでは「メディアグループ」と呼ばれる概念でリムーバブルメディアを管理しています。

メディアグループとは管理者が設定する仮想ディスク領域の名前で、管理者は複数のリムーバブルメディアを一つの大きな領域として設定することができ、クライアントはその領域につけられたメディアグループ名を選択してファイルの移動などを行います。

メディアグループ上のファイルの操作

メディアグループに転送されたファイルは、メインウィンドウで色分けして表示されます。それぞれの色の意味は次のとおりです。

白色
通常のファイルです
青色
メディアグループのファイルですが、ファイルを保存しているメディアがドライブ内にあるために比較的高速にアクセスできます
黄色
メディアグループのファイルで、ファイルを保存しているメディアはオートチェンジャ内の棚と呼ばれる場所にあるため、アクセスするためにはオートチェンジャのメディアの入れ替えが発生します
赤色
メディアグループのファイルですが、ファイルを保存しているメディアはオフラインになっているため、ファイルへの操作を行う場合はメディアをドライブまたはオートチェンジャに挿入する人的作業が発生します

メディアグループへ転送

再利用の頻度が低い保管を目的としたファイルは、メディアグループに転送することでデータの信頼性を高め、サーバのディスク容量を節約することが出来ます。

例えば開発が完了した製品のファイルをメディアグループに転送する手順は以下のようになります。

  1. 属性検索で[プロジェクト]グループの[プロジェクト名]="ChronoStar"を検索します
  2. 見つかったファイルをすべて選択し、メニューから[ツール]-[一括転送]を選択します
  3. [一括転送]ウィンドウが開きますので、[メディアグループ名]のリストから"ChronoStarの開発"を選択します

  4. [転送時期]に"夜間"を選択して[転送]をクリックします
  5. [メディア転送状況]ウィンドウが開き、転送予約されたことが確認できます

  6. 翌日クロノスターを起動して転送したファイルを再度検索すると、転送が完了しているので黄色（または青色）で表示されます
メディアグループにファイルを転送しても、検索やサムネイル表示は通常のファイルと同様に行うことができます。
  1. 以下のファイルは転送できません。これらのファイルを転送しようとすると警告が出ます
    • 承認待ちファイル
    • チェックアウト中のファイル
    • すでに転送予約されているファイル
  2. 一括転送は履歴を含めて転送されます
  3. 単一ファイルで転送先メディアの片面サイズを超えるものは転送できません

転送予約のキャンセル

一括転送で転送予約したファイルは、転送が行われるまでの間、予約をキャンセルすることができます。

キャンセルする手順は以下のようになります。

  1. メディア転送状況を開きます。
  2. [通常処理]または、[夜間処理]を開き、キャンセルしたいファイルを選択します。
  3. 右クリックを押し、[キャンセル]を押します。

  1. キャンセルするファイル数が多いと、画面の書き換えのためウィンドウが灰色になりますが、問題はありません。


CSV出力

3.9 CSV出力

クロノスターでは登録されているファイルの属性をCSV形式のファイルで出力することができます。

ファイル属性のCSV出力

クロノスターに登録されているファイルの属性をCSV形式でファイル出力することができます。

  1. 属性を出力したいファイルを選択します。該当ファイルをそれぞれ選択することもできますが、フォルダ内のすべてのファイルを対象とする場合はフォルダ自体を選択することもできます
  2. [ツール]メニューから[CSV出力...]を選択します
  3. 次のようなCSV出力ダイアログが表示されます
  4. [出力先]で[参照]ボタンをクリックしてファイル選択ダイアログを開きCSV形式のファイルを出力するパスとファイル名を指定します
  5. [出力する項目の選択]で、出力する項目をチェックします
  6. [OK]ボタンをクリックしてCSV出力を実行します


メール通知

3.10 メール通知

指定されたフォルダに新たにファイルが登録された時や、属性変更などデータベースの更新があったときに変更内容などをメールで通知することができます。

メール通知の設定は、バーチャルフォルダとワークフォルダに限定されます。システムフォルダに対してはメール通知の設定はできません。

メール通知設定

  1. バーチャルフォルダまたはワークフォルダを選択します
  2. [ツール]メニューから[メール通知設定...]を選択するか、フォルダ上でマウスの右ボタンをクリックしてメニューから[メール通知設定...]を選択します
  3. 次のようなメール通知設定ダイアログが表示されます
  4. [送信先]にメールの送信先を設定します。複数のメールはカンマで区切って入力します
  5. [件名(Subject)]にメールの件名を設定します
  6. [文頭文]にメール本文の文頭に表示される文章を設定します
  7. [表示属性]に[文頭文]に設定された文字列の後に表示される属性項目を設定します。[属性選択...]ボタンをクリックすると、属性選択ダイアログが表示されます。左側のリストから表示したい属性を選択し、[追加]ボタンをクリックします。設定が終了したら[OK]ボタンをクリックします
  8. さらに[詳細>>]をクリックすると、詳細項目の設定を行うことができます

    ［属性名を表示しない］チェックボックス
    このチェックを有効にすると、通知メールには属性の値のみが表示されます。無効にした場合には、”属性項目名： 属性値”という形式で表示されます。
    ［サムネイルを添付する］チェックボックス
    このチェックを有効にすると、通知メールに対象ファイルのサムネイル中（256x256）を添付します。
    ［URLを添付する］チェックボックス
    このチェックを有効にするとメール本文に対象ファイルのURLが表示されます。このURLは、ChronoStarWEBの詳細表示とほぼ同等のページに接続されます。
    ［登録ファイルを添付する］チェックボックス
    このチェックを有効にすると、通知メールに対象ファイル自身を添付します。
メール通知の設定は、バーチャルフォルダとワークフォルダに限定されます。システムフォルダに対してはメール通知の設定はできません。

メール通知一覧

  1. [ツール]メニューから[メール通知一覧]を選択します
  2. 次のようなダイアログが表示され、現在接続しているサーバに設定されているメール通知設定の一覧が表示されます


メール登録

3.11 メール登録

クロノスタークライアントを使わなくても、メールを用いてクロノスターへファイルを登録することができます。Windows以外のプラットホームからの登録やLANにつながっていない遠隔地からのファイル登録が可能になります。

メールテキストを登録する

以下の手順で、メールの内容をテキストファイルとしてクロノスターに登録できます｡

  1. メールを新規作成します｡
  2. 宛先に、クロノスターサーバのメールアドレスを設定します｡
  3. 件名に「メール登録」と設定します｡
  4. メール本文に以下のように入力します｡
    <Entry>
    <Body name="MailText.txt">
    ここにテキストファイルの内容を記述｡
    </Body>
    </Entry>
  5. メールを送信します｡

以上で、name="" に記述したファイル名でテキストファイルが登録されます｡

件名に書かれた内容は登録の動作に影響しませんが、登録完了時または登録エラー発生時に送信したメールを区別できるように、分かりやすい内容にすることをお勧めします｡

添付ファイルを登録する

メールの添付ファイルをクロノスターに登録する場合、メール本文には登録するファイルの属性を記述します｡以下の手順で、記述する属性の雛型をサーバから取得することが出来ます｡

  1. メールを新規作成します｡
  2. 宛先に、クロノスターサーバのメールアドレスを設定します｡
  3. 件名に「属性一覧取得」と設定します｡
  4. メール本文に以下のように入力します｡
    <List>
    <AG name="*"/>
    </List>
  5. メールを送信します｡
  6. サーバから属性グループの一覧が返信されるので、任意の属性グループを選択して次のように本文を書き直してもう一度メールを送付します｡
    <List>
    <AG name="設計"/>
    </List>
  7. これで以下のような雛型が返ります｡
    <Entry>
    <AG name="設計">
    <AT name="ファイル分類" value="デザイン,図面,提案書,プレゼン資料"/>
    <AT name="メディアタイプ" value="DVD-RAM,MO,CD,MD"/>
    <AT name="担当" value="鈴木,浅野,新田,西宮,森"/>
    </AG>
    <!--テキスト登録するときは、次のタグ内に記入してください。
    <Body>
    </Body>
    -->
    </Entry>
  8. 雛形から必要な項目を抜き出し、Value を設定します｡例えば次のように設定します｡
    <Entry>
    <AG name="設計">
    <AT name="ファイル分類" value="デザイン"/>
    <AT name="担当" value="鈴木"/>
    </AG>
    </Entry>
  9. 登録したいファイルを添付し、メールを送信します｡

タグ一覧

メール登録機能では、以下のXML形式のタグが使用できます｡

<List> </List>

  メール登録に使用する属性の一覧を取得する際に使用します｡
<AG name=""/> が必ず含まれます｡

<Entry> </Entry>

  メール登録本文は<Entry>で始まり、</Entry>で終わります。
  <AG name=""> や <Body name=""> を含みます｡

<AG name=""> </AG>

  属性グループを設定します。</AG>で終わります。
  namaには、クロノスターの属性グループ名を記述します。
  （例）<AG name ="テスト属性グループ">
  <AT name="">を含みます｡

<AT name="" value=""/>

  属性値を設定します。nameにクロノスターの属性名,valueに属性値を設定します。
  （例）<AT name ="テスト属性" value="メール登録"/>

<Body name=""> </Body>

  添付ファイルでなく、本文を登録することもできます。
  <Body>タグを使用すると</Body>までの内容がクロノスターに登録されます。
  nameには、ファイル名を指定します。

<Tag/> は <Tag></Tag>の省略形です｡


3.12 サムネイル変更

登録時に自動で取得されたサムネイルを変更することができます。

サムネイル変更

  1. システムフォルダまたはバーチャルフォルダまたはワークフォルダをから１ファイルを選択します
  2. [ツール]メニューから[サムネイル変更...]を選択するか、フォルダ上でマウスの右ボタンをクリックしてメニューから[サムネイル変更...]を選択します
  3. 次のようなサムネイル変更ダイアログが表示されます
  4. 変更したいサムネイルの画像ファイルを指定してください。もしくはクリップボードに貼り付けた後、貼り付けを実行してください。
  5. OKを実行してください。


インポート/エクスポート

3.13 ファイルのインポート/エクスポート

異なったクロノスターサーバ間でデータのやり取りを行います。

エクスポート

  1. システムフォルダまたはバーチャルフォルダまたはワークフォルダをからファイルを選択します
  2. [ツール]メニューから[ファイルのインポート/エクスポート...]->[エクスポート...]を選択します
  3. 次のようなエクスポートダイアログが表示されますので出力ファイル名を指定します。
  4. ただし、幾つかのフォルダが作成されますので、新しいディレクトリ内のファイルを指定してください。
  5. OKを実行してください。
  6. 出力された結果です。
  7. OKを実行してください。

    インポート

    1. [ツール]メニューから[ファイルのインポート/エクスポート...]->[インポート...]を選択します
    2. 次のようなインポートが表示されますので、エキスポートしたときのファイルを選択してください。
    3. 実行してください。
    4. インポートされた結果が、表示されます。


メール通知

3.14 操作履歴

クロノスターに対して操作を行った履歴が表示されます。

すべての操作に対して、履歴が表示されるものではありません。

操作履歴

  1. システムフォルダまたはバーチャルフォルダまたはワークフォルダから１ファイルを選択します
  2. [ツール]メニューから[操作履歴...]を選択するか、ファイル上でマウスの右ボタンをクリックしてメニューから[操作履歴...]を選択します


3.15 権限設定

クロノスターでは、セキュリティレベルに応じて次の権限設定が可能です。

レベル０ | 権限設定はできません
レベル１ | 属性グループに対する権限設定ができます
レベル２ | 属性グループと個々のファイルに対する権限設定ができます

バーチャルフォルダとワークフォルダの権限設定は、フォルダ自身を不可視にしたり、フォルダへの登録を制限したりする機能ではなく、そのフォルダに登録したファイルの権限の初期値となります。

権限設定

  1. フォルダまたはファイルを選択します
  2. マウスの右ボタンをクリックし、メニューから[権限設定...]を選択します
  3. 次のような権限設定ダイアログが表示されますので、グループまたはユーザに対する権限を設定します

    設定一覧
    ウィンドウの左側には、現在の設定がリスト表示されます。
    Read、Read/Writeのいずれかの設定にしてください。Writeのみの権限では登録できますが、ファイルが表示されません。

    [Read]
    このチェックが有効になっている場合、選択されているファイルまたはフォルダを参照する権限が設定されています。
    [Write]
    このチェックが有効になっている場合、選択されているファイルまたはフォルダを編集する権限が設定されています。
    [名前]
    Read/Write の設定対象となるユーザまたはグループを表します。
    [選択可能グループ]および[選択可能ユーザ]
    ウィンドウの右側には、権限の設定対象となるグループおよびユーザの一覧が表示されます。
    [<-グループ追加]
    選択可能グループ欄で選択されているグループを設定一覧のリストに追加します。
    [削除]
    設定一覧で選択されている設定を削除します。
    [<-ユーザ追加]
    選択可能ユーザ欄で選択されているユーザを設定一覧のリストに追加します。
    [OK]
    権限の編集を確定し、ウィンドウを閉じます。
    [キャンセル]
    権限の編集内容を破棄してウィンドウを閉じます。


オプション設定

3.16 オプション設定

[全般]タブ

[起動時にサーバー選択を行う]

起動時にサーバーを選択する場合には、チェックします。

[バーチャルフォルダ作成時、親フォルダの検索条件を引き継ぐ]

バーチャルフォルダを新規作成する際、検索条件のデフォルト値として親フォルダの検索条件を設定する場合にチェックします。

[システムフォルダからの削除では属性のみ削除する]

システムフォルダで一覧されているファイルを選択して[削除]コマンドを実行した場合、バージョン1.1では表示されているシステムフォルダに関連付けられた属性グループをファイルから削除するという動作を行っていました。このチェックを有効にすると、バージョン1.1同様、属性グループのみ削除する動作を行います。チェックを無効にすると、属性グループに関係なく、ファイルを削除します。

[ドラッグ＆ドロップ登録時、常に登録フォームを表示する]

メインウィンドウにエクスプローラからファイルをドラッグ＆ドロップで登録する場合、バージョン1.1では[Shift]キーを押しながらドラッグ＆ドロップを行うことで、登録ウィンドウを表示して登録を行うことができました。このチェックを有効にすると、[Shift]キーを押していなくても、ドラッグ＆ドロップ時に登録ウィンドウが表示されます。チェックを無効にすると、登録ウィンドウが表示されずに直接登録が実行されます。

[読み取り専用で開く]

ChronoStarからファイルを開く時に、ファイルを読み取り専用で開くことができます。

[一括転送後、転送状況を表示する]

このチェックを有効にすると、[一括転送]コマンドを実行した際に転送状況を確認するウィンドウが表示されます。

[ダブルクリック時の機能]

このオプションは、メインウィンドウのファイルリストをダブルクリックしたときの動作を決定します。

属性表示
[ファイル]-[属性]を実行します
イメージ表示
[ファイル]-[イメージ表示]を実行します
開く
[ファイル]-[開く]を実行します

[マルチイメージ画像サイズ]

マルチイメージ表示時の画像のサイズを選択します。

[テンポラリディレクトリ]

このオプションは[開く]などのコマンドで使用されるディレクトリを設定します。テンポラリディレクトリを変更する場合は、[参照]ボタンをクリックして、テンポラリディレクトリを選択します。

クロノスターを長期間使用するとテンポラリディレクトリにファイルが溜まっていきますので、[クリア]ボタンを定期的に押して一時ファイルを削除してください。

[検索]タブ

[検索の最大表示件数]

このオプションをチェックして[指定件数]を設定すると、メインのリストに表示されるファイル数を制限することができます。ネットワークの速度が遅い場合やクライアントマシンの処理能力が低い場合などはこのオプションで表示件数を制限しておき、必要なときだけチェックを外すようにするとよいでしょう。

[終了時に検索結果フォルダを削除]

クロノスターでは検索が実行されると自動的にバーチャルフォルダが作成されます。このオプションをチェックしておくと、検索結果として作成されたフォルダを自動的に削除することができます。

検索結果フォルダの名前を別の名前に変更すると、終了時に削除される対象ではなくなります。

[リンク追跡階層]

循環リンクをさけるために、リンクを追跡する深さを設定します。

[３D表示]タブ

[オブジェクト数の設定]

ブック・スライダで一度に表示できるファイルの上限を設定します。

[画面切り替え時の特殊効果]

オブジェクト数で設定した値を超える場合に、あらたにオブジェクトをサーバから読み込みます。この切り替わり時に表示がどのように切り替わるかを指定します。

[３D表示の設定]

このオプションは３Dの表示効果を設定します。

[霧]チェックボックス
設定すると、全体にぼんやりします
[床]チェックボックス
設定すると、床を表示します
[補間]チェックボックス
画像を変形するときに補間してひずみをすくなくします
[陰]チェックボックス
サムネイルの陰を生成します

[３Dサムネイル表示にアイテム番号を表示]

サムネイルの番号を３Dサムネイルに表示します。。

[ブックビューにページ番号を表示]

ブックでは、１ページに複数のファイルを配置できるためページ番号を振れるようにします。

[パスワード]タブ

ローカルログインを使用している場合、ここでパスワードの変更を行うことが可能です。

[最適配置]タブ

分散最適配置オプションを使用している場合、ここで最適配置の設定を行うことができます。


ＴＩＰＳ

3.17 ＴＩＰＳ --- 知っていると便利 ---

操作

  • 操作に割り当てられているショートカットキー
  • 検索項目をキーボードで入力
  • フォルダの中身をまとめて登録
  • エクスプローラの[送る]メニューから登録実行
  • URLを属性値に設定
  • 複数ファイルの属性値をまとめて削除する

運用

  • チェックアウト状況ウィンドウの利用
  • URLショートカットの直接登録

操作に割り当てられているショートカットキー

他のアプリケーション同様、クロノスターでもコマンドにキーボードショートカットが割り当てられています。

コマンド名 | ショートカット
編集 | すべて選択 | Ctrl+A
表示 | 詳細 | Ctrl+L
マルチイメージ | Ctrl+M
スライダ | Ctrl+S
ブック | Ctrl+B
検索 | 全文検索 | Ctrl+F

検索項目をキーボードで入力

クロノスターの検索条件設定は、検索項目を検索パネルにドラッグ＆ドロップする独特な方法で行います。この方法は検索条件を必要なだけ自由に設定できる反面、ドラッグ＆ドロップの苦手な方には操作しづらいという欠点があります。[検索属性]ウィンドウで検索項目を選択し、Shiftキーを押しながらリターンキーを押すと、選択されている検索項目が検索パネルに追加されます。

フォルダの中身をまとめて登録

ローカルフォルダのファイルを登録する際、エクスプローラでフォルダを選択してクロノスターにドラッグ＆ドロップすると、ドロップしたフォルダに含まれるすべてのファイルを階層的に探し出して登録します。この機能を使えばローカルディスク上のファイルをまとめて登録する場合には、一番上のフォルダをドロップするだけで登録が完了します。

エクスプローラの[送る]メニューから登録実行

クロノスターの登録専用クライアントは、起動パラメータとしてファイルを受け付けるため、登録専用クライアントのショートカットをエクスプローラの[送る]メニューに追加すると登録が簡単になります。

Windowsに詳しい方のみが設定してください。

URLを属性種類に設定

クロノスターの属性種類にURLを選択すると、クリックでWebブラウザを開くことができます。ファイルの関連情報がインターネット上にある場合は、属性種類にURLを設定すると便利です。

複数ファイルの属性値をまとめて削除する

システムフォルダでファイルを検索して[削除]コマンドを実行した場合、ファイルに複数の属性グループが設定されていると属性グループの削除のみを行います。この機能を利用することで、複数のファイルに設定された属性グループをまとめて削除することができます。

ただし、ファイルに１つの属性グループしか設定されていない状態で[削除]を実行すると実際のファイルも削除されますので、そのようなファイルに対してはこの方法を行わないで下さい。

チェックアウト状況ウィンドウの利用

チェックアウトされたファイルはメインウィンドウではアイコンが変化して通常のファイルと区別されていますが、チェックアウト状況を利用するとより効率的にファイルの編集が可能です。

チェックアウト状況は［ツール］－［チェックアウト状況］で起動します。起動すると自分のチェックアウトしているファイルの一覧がウィンドウに表示され、チェックアウト日時やチェックアウト理由なども一覧できます。

また、［表示］－［自分のファイル］のチェックを外すと他の人がチェックアウトしているファイルも確認できるため、他の人が編集中でチェックアウトできないようなときに、誰が何のために編集しているかを確認する事ができます。

ファイルの編集は一日で完了するとは限りませんが、チェックアウト状況では［ファイル］－［開く］コマンドがチェックアウト先のファイルを開くようになっていますので、編集の継続を行う事ができます。また、チェックインも［ファイル］メニューの下にありますので便利です。

URLショートカットの直接登録

インターネットの情報をグループで共有したい場合、クロノスターを利用すると便利です。クロノスターではMicrosoftのインターネットエクスプローラのアドレスバーに表示されているショートカットアイコンを直接登録する機能が用意されています。また、URLに属性を設定して登録できるため、あとで効率的に検索し、見つけ出すことができます。

  1. 共有ワークフォルダに新規にフォルダを作成します。
  2. インターネットエクスプローラで登録したいWebページを表示します。
  3. [アドレス]バーのアイコンを新規に作成したフォルダツリー上にドラッグ＆ドロップで登録します。


サーバ管理

4. サーバ管理

クロノスターサーバを管理するのに必要な機能を説明します。

  • 4.1 ライセンス設定
  • 4.2 アドミニストレーションプログラム
  • 4.3 属性設定
    • - 属性設定の起動
    • - 属性設定の終了
    • - 属性グループの作成
    • - サブ属性グループの作成
    • - 属性項目の作成
    • - 固定入力値の作成
    • - 各アイテムの削除
    • - 位置の変更
    • - システムフォルダの設定
    • - 権限の設定(オプション機能)
    • - 属性項目の詳細設定
    • - 属性グループのエクスポートとインポート
  • 4.4 セキュリティ設定
    • - 属性グループの選択
    • - 権限の設定
  • 4.5 領域作成
    • - 固定ディスクの領域設定
    • - 固定ディスクの領域削除
    • - チェンジャメディアグループの領域設定
    • - ドライブメディアグループの領域設定
  • 4.6 承認グループ作成
    • - 承認グループを作成する
  • 4.7 ユーザ管理
    • - ユーザ登録
    • - ユーザ情報の変更
    • - ユーザ削除
    • - グループ作成
  • 4.8 システム設定オプション
    • - 全般
    • - メール機能
    • - リムーバブル連携オプションがある場合
  • 4.9 信頼性エージェント設定
    • - 信頼性エージェントの設定手順
    • - 設定可能なフィルタの種類
  • 4.10 メディア入出
    • - メディアの排出(オフライン化)
    • - オフラインメディアの挿入
    • - 転送状況の確認
  • 4.11 アクセスログ
    • - アクセスログを閲覧する >

  • 4.12 フォルダ監視設定
    • - フォルダ監視設定の起動
    • - 監視フォルダの設定

  • 4.13 ＣＳＶ登録ツール
    • - 基本設定
    • - 詳細設定
    • - 自動実行


ライセンス設定

4.1 ライセンス設定

アドミニストレーションプログラムは、製品ごとに設定されているシリアルナンバーとライセンスコードを入力するまで各種の管理機能は使用できない状態となっています。

ライセンス設定を行うまでに使用できる機能はバージョン情報、ライセンス設定、終了の3つです。
ライセンス設定を使用して各機能を使用できる状態にする必要があります。ライセンス情報の設定は｢ライセンス設定｣ボタンをクリックします。

シリアルナンバーには製品に同梱されているシリアルナンバーを入力します。ライセンスコードは製品に同梱されているライセンス発行シートに必要事項をご記入の上、弊社までご請求ください。ライセンスコードを入力して｢OK｣ボタンをクリックします。

正しいシリアルナンバーとライセンスコードの入力により各機能が使用できるようになります。一旦入力されたシリアルナンバーとライセンスコードはデータベースに記憶されますので次回からは、ライセンス設定を行なう必要はありません。


アドミニストレーションプログラム

4.2 アドミニストレーションプログラム

クロノスターの運用管理のための設定作業には、アドミニストレーションプログラム（以下、アドミン）と呼ばれる管理ツールを使用します。

アドミンのインストールされているマシン（通常サーバマシン）で［スタート］-［ChronoStar］-［管理ツール］の順で選択するとアドミンのメインウィンドウが開きます。

サーバ名の欄に設定を行いたいサーバを選択してからボタンをクリックすることで各々の設定を行うツールが起動します。

各ボタンの内容は次の通りです。

ボタンキャプション | 内容
領域作成 | 登録ファイルを格納する場所の設定を行います。
属性設定 | 登録ファイルにつけられる属性項目を設定します。
承認グループ作成 | 登録ファイルのオンライン承認機能に使用する承認ルートを設定します。
信頼性エージェント設定 | 登録時のフィルタを設定します。
メディア入出 | オートチェンジャを使ったシステムの場合に、メディアの出し入れを行います。
ユーザ管理 | ログインユーザを登録します。
システムオプション設定 | サーバオプションを設定します。
アクセスログ情報 | アクセスログ情報を表示します。
ライセンス設定 | ライセンスコードを入力します。
バージョン情報 | アドミンのバージョンを表示します。
終了 | アドミンを終了します。


属性設定

4.3 属性設定

1. 属性設定の起動

アドミンのメインウィンドウでサーバ名を選択し、［属性設定］ボタンをクリックします。

2. 属性設定の終了

編集内容をデータベースに保存して終了する場合は[OK]ボタンをクリックします。編集内容を破棄して終了する場合は[キャンセル]ボタンをクリックします。

3. 属性グループの作成

ファイル管理を行うための属性グループを新規に作成します。[属性]メニューから[新規作成]-[属性グループ]の順で選択します。新しい属性項目が追加されます。

属性グループ欄を編集して作成したい属性グループの名称に変更します。ここでは｢部品管理｣とします。

｢部品管理｣属性グループが作成されました。

この属性グループを使用した同名ファイルの登録を制限したい場合は｢同名ファイルの登録を禁止する。｣をチェック状態とします。

4. サブ属性グループの作成

関連のある属性項目のまとまりごとにサブ属性グループを作成します。サブ属性グループは必ず1つ以上必要です。サブ属性グループを作成する属性グループ名を選択し、[属性]メニューから[新規作成]-[サブ属性グループ]の順で作成します。属性グループを選択し、マウスの右ボタンをクリックして、[新規作成]-[サブ属性グループ]の順で選択してもサブ属性グループを作成することができます。

サブ属性グループ欄を編集して作成したいサブ属性グループの名称に変更します。ここでは｢図面｣とします。ここでは、もうひとつのサブ属性グループとして｢製作｣を作成します。

サブ属性グループはChronoStarクライアントでは属性表示のタブとして表れます。

5. 属性項目の作成

属性値を管理する項目を作成します。属性項目を作成するサブ属性グループ名を選択し、[属性]メニューから[新規作成]-[属性項目]の順で選択します。なお、属性グループを選択し、マウスの右ボタンをクリックして、[新規作成]-[属性項目]の順で選択しても属性項目を作成することができます。

属性項目欄を編集して作成したい属性項目の名称に変更します。ここでは｢図面｣サブ属性グループに｢図番を作成します。属性項目は型が設定できます。文字列、日付、数値、数値(範囲指定)、URL、チェック、選択の7種類から選びます。

それぞれの型に応じて詳細設定を行います。詳しくは「11属性項目の詳細設定.」を参照してください。

  • サブ属性グループに作成できる属性項目数は無限ですがクライアントの属性表示ウィンドウでサブ属性グループ毎に表示可能な属性項目は段数設定が1(初期値)の属性項目の場合、最大10個です。(段数設定の合計数≦10)
  • 型を設定できるのは新規作成時のみで、運用を開始後は変更できません。詳細設定は運用を開始した後でも変更が可能です。

6. 固定入力値の作成

属性項目によく使用する値がある場合、メニューから属性値が選べるようにあらかじめ設定しておくことができます。属性値を作成する属性項目を選択し、[固定値入力]メニューから[新規作成]を選択します。なお、属性項目を選択し、固定入力値一覧上でマウスの右ボタンをクリックして、[新規作成]を選択しても属性値を作成することができます。

「新しい項目」という名前で固定入力値が追加されますので、名前を変更します。

7. 各アイテムの削除

属性グループ、サブ属性グループ、属性項目、属性値の各アイテムは削除できます。削除したいアイテムを選択し、削除ボタンをクリックします。ただし、属性グループの削除は、その属性グループを使用して管理しているファイルが検索できなくなりますので慎重に作業してください。その属性グループを使用した登録ファイルがある場合は警告しますので確認後処理を継続してください。

8. 位置の変更

各アイテムは同一階層内で順序を変更できます。順序を変更するアイテムを選択し、マウスの右ボタンをクリックして[位置の変更]-[上へ]または[下へ]を選択します。属性項目は属性グループ内であれば別のサブ属性グループにも移動することができます。

9. システムフォルダの設定

ChronoStarクラアイントのシステムフォルダとして表示する為には、システムフォルダの階層設定を行います。階層設定は属性項目アイテムを選択してシステムフォルダの階層欄の上下ボタンで数値を調整します。ここでは｢設計者｣を第1階層、｢部品種別｣を第2階層、｢図面サイズ｣を第3階層に設定します。

ChronoStarクライアントでは次のようなシステムフォルダとして使用できます。

10. 権限の設定(オプション機能)

各属性グループの読み込み/書き込み権をグループおよびユーザ単位で設定できます。読み込み権がないグループおよびユーザには、属性グループとその属性グループとその属性グループを使用して登録しているファイルが見えなくなります。書き込み権がないグループおよびユーザは属性グループの追加/削除/属性変更とその属性グループを使用して登録しているファイルの編集、リンクの登録などができなくなります。

右側のリストに選択可能なグループ名とユーザ名の一覧が表示されます。読み込み権または書き込み権を設定するグループまたはユーザをリストから選択し、［グループ追加］ボタンまたは［ユーザ追加］ボタンをクリックします。選択されたグループまたはユーザは左側のリストに追加されます。読み込み権と書き込み権を設定する場合はグループまたはユーザの前にあるチェックボックスをクリックしチェックマークを付けます。<Everyone>は特殊なユーザ名で不特定のユーザを表します。選択可能なグループやユーザは、「ユーザ管理」で設定します。

11. 属性項目の詳細設定

1.項目型

新規作成時のみ型を選択して設定できます。

型 | 内容 | 属性値の作用
文字列 | 最も一般的な型で数字、英字、記号、漢字が入力できる型です。 | 属性値の設定がある場合はドロップダウンリストから選択する入力方法を選択できます。
数値 | 数値を入力できる型です。比較式を使用した検索や単位記号を使用しても数値として扱いたい場合に使用します。数値型、数値(範囲指定)は最大255まで指定できますが、有効桁数は9桁です。9桁までの指定にしてください。
日付 | 日付として検索したい場合に使用します。カレンダによる入力方式を利用できます。 | 属性値の設定内容は無効となります。
数値(範囲指定) | 上限値と下限値を制限したい場合に使用します。入力方法はスライダ方式となります。数値型、数値(範囲指定)は最大255まで指定できますが、有効桁数は9桁です。9桁までの指定にしてください。 | 2つの数値を設定します。1番目の値が下限値、2番目の値が上限値となります。正しく動作させる為には必ず設定してください。
URL | 入力値はURLと見なします。属性表示の値をクリックすることで設定された先にジャンプします。WEBの情報をリンクしたい場合に使用します。 | 属性値の設定内容は無効となります。
チェック | ONかOFFの2通りの状態しか選べない型です。
選択 | あらかじめ設定されている選択肢からひとつの値を選択できる型です。 | 設定された属性値が選択肢として表示されます。

2.入力方法

入力方法 | 内容
標準 | 最も一般的な入力方法で、手入力かドロップダウンリストからの選択入力が行えます。(ドロップダウンリストが使用できるのはあらかじめ属性値が設定されている場合のみです。)
選択肢から選択 | ドロップダウンリストからの選択入力のみとなります。手入力の必要がない場合に選択します。
初期値もしくは自動設定値 | 入力ができません。初期値や自動採番などシステムが生成した値(カスタム)を使用する場合に選択します。
必須入力項目 | 必ず入力が必要な項目はチェック状態とします。

3.書式設定

数値型の場合のみ有効な設定でカンマの挿入、金額記号の付加、単位記号の付加を設定できます。

4.長さ

入力文字数の上限を設定できます。1～255の範囲で設定できます。半角文字数で換算した値を設定します。初期値は64です。数値型、数値(範囲指定)は最大255まで指定できますが、有効桁数は9桁です。9桁までの指定にしてください。

5.小数点以下の長さ

数値型の場合のみ有効な設定で小数点以下の長さを設定します。初期値は0です。

6.段数

文字列型の時に有効な設定で複数行の入力欄を作成する場合に設定します。初期値は1段で1行入力となります。2以上に設定された場合は複数行での入力と表示が行えます。2に設定された場合は通常の属性項目の高さ2つ分の大きさの入力欄となります。サブ属性グループに項目を1つだけ設定する場合は最大10段の入力欄を作成できます。

7.初期値

通常の設定では新規登録時に属性値欄が空欄となりますが、ここに値が設定された場合は初期値として使用します。入力方法で｢初期値もしくは自動設定値｣が選択されている場合は、いつも決まった値を設定して変更できないようにすることができます。

8.説明文

入力項目の説明文がツールチップで表示されるようになります。

9.IMEの初期設定

入力開始時にIME設定を半角か全角に変更することができます。入力開始後にIMEの設定は変更できるので半角か全角の入力を保証する設定ではありません。

10.数字以外の文字制限

文字列型を選択した場合で数字以外の値を入力できないようにしたい場合に設定します。

12．属性グループのエクスポートとインポート

同一構造の属性グループを複数個作成する場合は属性グループのエクスポートとインポート機能を利用して複製を作成するのが便利です。複製元となる既存の属性グループを選択して［属性］メニューから[エクスポート]を選択します。

編集したばかりの属性グループ情報はエクスポートされませんので｢いいえ｣をクリックして処理を中断した後、保存終了してから再度実行してください。属性グループの編集をしていない場合は｢はい｣をクリックして処理を継続します。

出力するCSVファイル名を入力して保存をクリックします。

次に[属性]メニューから[インポート]を選択し、今保存したCSVを選択して開くをクリックします。

CSVにある属性グループ名で追加されます。
すでに同名の属性グループがある場合は「部品管理(1)」というように属性グループ名のあとに数字が付けられますので、これを別の名称に変更します。

  • エクスポートしたCSVファイルの内容を編集して余分な情報を削除したり追加してからインポートすることは可能ですがサポートできない書式に編集された場合はインポートでエラーを発生する場合があります。


セキュリティー設定

4.4 セキュリティー設定

クロノスターでは、管理者が属性グループ毎に読み出し/書き込みできるユーザを設定することができます。

属性グループの選択

アドミンのメインウィンドウでサーバ名を選択し、［属性設定］ボタンをクリックします。
権限設定を行う属性グループを選択します。

セキュリティーレベル０では、設定された権限は無視されます。

権限の設定

［属性］メニューから［権限設定］を選択し、権限設定画面を表示します。

ここでは、属性グループに対して、ユーザ単位で読み込み/書き込み権を設定することができます。

右側のリストに選択可能なグループ名とユーザ名の一覧が表示されます。読み込み権または書き込み権を設定するグループまたはユーザをリストから選択し、[グループ追加]ボタンまたは[ユーザ追加]ボタンをクリックします。
選択されたグループまたはユーザは左側のリストに追加されます。読み込み権と書き込み権を設定する場合はユーザの前にあるチェックボックスをクリックしチェックマークを付けます。<Everyone>は特殊なユーザ名で不特定のユーザを表します。

権限レベル | 制限される機能
読み込み権のないユーザ | 登録 | 該当属性グループのシステムフォルダが表示されない。
 |  | 追加できる属性グループとして表示されない。
 | 属性編集 | 属性グループの追加と削除ができない
 |  | 属性グループが複数個設定されているデータは該当する属性グループの属性値が非表示となる。
 | 検索 | 属性グループが検索項目として表示されない。
 |  | 属性グループが付加されたデータは検索結果として表示されない。
書き込み権のないユーザ | 登録 | 該当属性グループのシステムフォルダにD&D登録できない。
 |  | 追加できる属性グループとして表示されない。
 | 属性編集 | 属性グループの追加と削除ができない。
 |  | 属性値の書き換えができない。
 | 名前変更 | 名前の変更ができない。
 | 編集 | チェックアウトできない。(改訂ができない。)
 | 削除 | 削除ができない。
 | リンク | リンクの登録ができない。
権限設定は、その属性グループの設定を保存するまで反映されません。
使用ユーザの一覧では、ローカルログインユーザ(ローカルログインモード時)またはドメインユーザ(ローカルログインモード以外)が表示されます。
権限管理の有効/無効とドメインの設定は、システムオプションで行います。
ローカルログインユーザの作成は、ユーザ管理で行います。
Read、Read/Writeのいずれかの設定にしてください。Writeのみの権限では登録できますが、ファイルが表示されません。
ChronoStarのセキュリティーモデルをレベル2で運用された場合、ファイルをChronoStarへ登録した場合、登録ユーザのみ権限が付加されます。その他のユーザは表示されません。ただし管理者権限が付加されたユーザに関しては全てのファイルが表示されます。


領域作成

4.5 領域作成

領域作成ツールでは、クロノスターに登録されたファイルを格納する領域を設定します。

固定ディスクの領域設定

アドミンのメインウィンドウでサーバを選択して［領域作成］ボタンをクリックすると以下の画面が起動します。

[固定ディスク]タブでは、クロノスターのデータ領域に起動したマシンのディスク領域を追加することができます。

データ領域の追加手順

  1. ［固定ディスク］タブを選択します
  2. ［作成区分］として［データ領域］を選択します
  3. ［ドライブ名］のリストでクロノスターのデータ領域として使用したいパーティションのチェックボックスをチェックします
  4. ［作成］ボタンをクリックします

以上の操作で指定したハードディスクに専用のフォルダが作成され、クロノスターのデータ領域として使用されるようになります。

固定ディスクの領域削除

一度設定した領域は基本的に運用後、解除できません。しかし、領域作成直後、何も登録されていない場合に限り領域を削除することができます。

データ領域の削除手順

  1. ［固定ディスク］タブを選択します
  2. ［作成区分］として［データ領域］を選択します
  3. ［ドライブ名］のリストでチェックボックスのチェックを外します。
    このとき、[作成]ボタンが[削除]ボタンに変わります。
  4. ［削除］ボタンをクリックします

チェンジャメディアグループの領域設定

オートチェンジャの接続されているマシン上で領域作成を起動すると、以下のように[固定ディスク]タブの他に［リムーバブルディスク］のタブが表示されます。

[リムーバブルディスク]タブでは、チェンジャメディアグループの領域を編集することができます。

メディアグループの作成手順

  1. [リムーバブルディスク]タブを選択します。単独のリムーバブルディスクドライブが接続されている場合は[ドライブ]と[チェンジャ]が選択できますが、ここでは[チェンジャ]を選択します。
  2. [メディアグループ名]にこれから作成するメディアグループの名前を入力して[作成]ボタンをクリックします。。

  3. [メディア名]のリストから｢(空きスロット)｣と表示された行を選択し、マウスの右クリックメニューから[作成]を選択します。

  4. メディアグループは複数のメディアをひとつの仮想的な領域として設定できますので、上記手順で必要なだけスロットを選択します。選択が完了したら、ウィンドウの一番下にある[作成]ボタンをクリックします。

  5. システムからディスクの挿入を促すメッセージが表示されますので、ディスクに指示されたラベルを貼った後、オートチェンジャのメールスロットに挿入して[OK]ボタンをクリックします。

  6. 複数のメディアを設定している場合は上記動作を繰り返します。このとき、次のメディアの挿入は前のメディアの挿入処理が完了してから行ってください。クボタ製DVDオートチェンジャではメディアの挿入完了時に[ピピッ！]と音が鳴ります。
  7. メディアの挿入が終わると、メディアにIDを書き込む処理が開始されます。処理が完了すると[閉じる]ボタンが有効になりますので、[閉じる]をクリックして作業を完了してください。

ドライブメディアグループの領域設定

オートチェンジャがないシステムでも、SCSI接続されたDVDドライブやMOドライブがあればオフライン管理機能を使用できます。

単独のリムーバブルディスクを使用してオフライン管理をするためには、以下の手順でドライブメディアグループを作成してください。

  1. [リムーバブルディスク]を選択してください。[ドライブ]が自動的に選択されます。

  2. [ドライブ]の横のドロップダウンリストから、リムーバブルディスクの接続されたドライブを選択してください。

  3. [メディアグループ名]をドロップダウンから選択するか新規に入力します。ドロップダウンから選択する場合、既存のメディアグループにメディアを追加する操作になります。新規に名前を入力した場合は、新しいメディアグループの１枚目のメディアを作成します。新規に名前を入力した場合は[メディアグループ名]の横に小さな[作成]ボタンが表示されますので、[作成]ボタンをクリックして名前を確定してください。

  4. メディアグループを指定したら、[設定]ボタンをクリックします。[メディア名]の欄に「メディアグループ(メディア番号)」の名前が自動的に生成されます。

  5. これで設定が完了しましたのでウィンドウの一番下にある[作成]ボタンをクリックします。

  6. ドライブにメディアを挿入するように指示が出ますので、フォーマット済みのメディアをドライブに挿入して[OK]をクリックします。これでメディアにIDが書き込まれ、クロノスターから認識できるようになります。

  7. AB両面へのIDの書き込みが完了したら、メッセージに従ってメディアにラベルを貼って下さい。


承認グループ作成

4.6 承認グループ作成

承認グループ作成では、クロノスターの承認機能で使用される承認ルートを設定します。

クロノスターでは承認者のリストを事前に管理者が設定し、承認処理を実行する際にはその承認者のリストから選択するようになっています。この承認者のリストを承認グループと呼びます。

承認グループを作成する

  1. アドミンのメインウィンドウから、［承認グループ作成］ボタンをクリックします。以下に示す承認グループの作成方法を順に説明していきます。

  2. クロノスターでは、承認ルートそのものである承認グループと、関係のある承認グループをまとめる親グループで構成されます。まず、[編集]メニューから[新規親グループ作成]を選択すると新しい親グループが作成されます。

  3. 親グループの名前として”営業部”を設定します。

  4. 作成した親承認グループをマウスで選択し、メニューから[編集]－[新規グループ作成]を選択して承認グループを作成します。”第1営業”と名前を入力します。承認グループの名前が確定した段階で選択可能ユーザが表示されます。

  5. 選択可能ユーザから追加するユーザをマウスで選択して[追加]ボタンをクリックし、承認ルートに承認者を追加します。（SHIFT、CTRLとクリックを併用することで複数ユーザの選択が可能です。）

  6. 次に承認ルート内のユーザの順番を希望の順番に変更するために、承認ルート内のユーザをマウスで選択して[前へ]、[後へ]ボタンで順番を変えます。
  7. さらに、代理承認を設定する場合には、承認ルートで代理承認を加えるユーザを選択し、選択可能ユーザから代理者を選択し、[代理]ボタンをクリックします。

  8. ［登録］をクリックしてルートを確定します。

  9. 同様の手順で、営業２課、営業３課、開発部を作成します。承認ルートの作成が完了したら、［閉じる］をクリックしてウィンドウを閉じます


ユーザ管理

4.7 ユーザ管理

クロノスターにログインできるユーザおよびグループの管理を行います。
ChronoStar1.1のセキュリティモデルを1で運用されていて2.2に移行した場合はご相談ください。権限設定が移行されません。

ユーザ登録

  1. アドミンツールの[ユーザ管理]ボタンをクリックします
  2. [ユーザ]メニューから［新規作成...］を選択するとユーザ作成ダイアログが表示されます
  3. [ユーザ名]にユーザの名前を入力します
  4. [表示名]にユーザリストなどに表示される名前を入力します
  5. [パスワード][パスワードの確認]にパスワードを入力します。実際の画面にはパスワードは「***」で表示されます
  6. [説明]にユーザ情報など自由に入力することができます
  7. [管理者権限を与える]管理者権限を与える場合はチェックしてください。ChronoStar1.1もしくは2.0以降から移行の場合は、再度設定しなおしてください。
  8. [電子メールアドレス]メール通知、メール承認で使用します。ChronoStar1.1もしくは2.0以降から移行の場合は、再度設定しなおしてください。

ユーザ情報の変更

  1. アドミンツールの[ユーザ管理]ボタンをクリックします
  2. ユーザ一覧で変更したいユーザを選択します
  3. [ユーザ]メニューから[プロパティ...]を選択します
  4. プロパティダイアログが表示されますので、項目を変更後、[OK]ボタンをクリックします。変更を取り消す場合は[キャンセル]ボタンをクリックします

ユーザの削除

  1. アドミンツールの[ユーザ管理]ボタンをクリックします
  2. ユーザ一覧で削除したいユーザを選択します
  3. [ユーザ]メニューから[削除]を選択します

グループの作成

各ユーザが所属するグループを作成します。グループは階層構造で作成することができます。第一階層目に指定したユーザは第二階層目以降には反映されません。各階層のグループ毎でユーザ設定を行うようにしてください。

  1. 第一階層目にグループを作成する場合は、グループ一覧の余白部分で、マウスの右ボタンをクリックし、[新規作成]を選択します。第二階層目以降にグループを作成する場合は、グループを選択し、[グループ]メニューから[新規作成]を選択するか、マウスの右ボタンをクリックし[新規作成]を選択します。
  2. グループ名を入力します
  3. グループに属するメンバーを設定するには、グループを選択し、[選択可能なユーザ]一覧からユーザ名を選び、[<追加]ボタンをクリックします。グループからメンバーを削除する場合は、メンバー一覧から削除したいユーザ名を選択し、[メンバー削除]ボタンをクリックします


システム設定オプション

4.8 システムオプション設定

全般

このウィンドウではクロノスターのシステム運用のためのオプション設定を行います。

オプションを設定して[更新]または[OK]ボタンをクリックすると動作が反映されます。[更新]ボタンをクリックせずに[キャンセル]ボタンをクリックすれば変更は破棄されます。

[チェックアウト時に必ず改訂]
この項目を有効にすると、クライアントで[チェックアウト]を行う際に必ず改訂を行うように動作します。デフォルトの設定は[無効]です。この項目は次バージョンのクライアントから有効となります。
[改訂番号の自動入力]
この項目を有効にすると改訂処理実行時に自動的にファイルバージョンを付加します。任意の記号を入力して管理したい場合は、この項目を無効にします。デフォルトの設定は[有効]です。この項目は次バージョンのクライアントから有効となります。
[改訂番号の制限]
改訂番号、記号を入力するときに、入力文字の制限が行えます。
[ドキュメントの削除は管理者のみ実行可能]
この項目を有効にするとユーザ管理で管理者権限を与えるが有効になっているユーザのみファイルの削除メニューが表示され、削除することが可能になります。ChronoStar2.0の[管理者権限を与えるユーザ名]とほぼ同等の機能になります。
[共有バーチャルは管理者のみ編集可能]
この項目をチェックすると共有バーチャルフォルダの条件設定、名前変更などは、管理者のみ実行可能となり、一般ユーザは変更、名前変更などできなくなります。デフォルトではチェックされていません。
[共有ワークは管理者のみ編集可能]
この項目をチェックすると共有ワークフォルダの名前変更、削除などは、管理者のみ実行可能となり、一般ユーザは名前変更、削除などできなくなります。デフォルトではチェックされていません。
[チェックアウト時ファイルの置換可能]
この項目をチェックするとチェックアウト時に、異なった拡張子のファイルに入れ替えることが可能になります。ただしファイル名（拡張子を除く）は同じ必要があります。例えば、TIFファイルで作成されたファイルからCADデータへファイルに入れ替えることが可能になります。デフォルトではチェックされていません。
[セキュリティーレベル]
システムのセキュリティを設定します。デフォルトの設定値は0です。セキュリティレベルは運用を始めての変更はできません。変更した場合、登録済みのファイルが表示されないことがあります。
レベル0：セキュリティの設定を行いません
レベル1：属性グループごとに設定を行います
レベル2：属性グループとファイルごとに設定を行います。ファイルをChronoStarへ登録した場合、登録ユーザのみ権限が付加されます。その他のユーザは表示されません。
[ユーザ管理をするドメイン]
ユーザ情報を取得するドメインを設定します。ユーザ情報はセキュリティー機能で使用します。デフォルトでは空白に設定されます。指定できるドメインは一つです。よって複数のドメインで管理されている場合はご利用できません。ドメインにユーザを追加した場合は、ユーザ管理を一度起動してください。ユーザ管理を起動することにより、ドメインからChronoStarへユーザ情報を取得します。
[管理者権限を与えるユーザ名]
管理者権限を持つユーザのログイン名を設定します。ChronoStar2.1から本機能は、[ドキュメントの削除は管理者のみ実行可能]に変わりました。
[電子メール承認]
承認処理で電子メール通知機能を設定します。
[ローカルログイン]
クロノスターに登録されているユーザ情報を元にログイン認証を行います。

メール機能

メール通知、メール登録のために、SMTPサーバ名、POPサーバ名などを設定します。

オプションを設定して[更新]または[OK]ボタンをクリックすると動作が反映されます。[更新]ボタンをクリックせずに[キャンセル]ボタンをクリックすれば変更は破棄されます。

[SMTPサーバ名]
SMTPサーバ名を設定します。
[POPサーバ名]
POPサーバ名を設定します。
[ログインユーザ名]
POPサーバにログインするためのユーザ名を設定します。メール登録を使用するときのみ ChronoStar登録用の専用ユーザを作成してそのユーザ名を設定してください。一般ユーザを設定しないでください。また通知者アドレスと同じユーザを指定しないでください。
[パスワード]
ログインユーザのパスワードを入力します。
[パスワード(確認用)]
確認のためパスワードをもう一度入力します。
[通知者アドレス]
通知メールのFrom:になるユーザ名を入力します。
[通知者URL用サーバ名]
メール通知のＵＲＬ通知で使用されるChronoStarWebサーバの名前を入力します。通常はサーバ名のままで問題はありませんが、 　　インターネット用のFQDN(完全装飾ドメイン名)を使用したり、IPアドレスを記述することにより、メールを受け取った環境でもアクセスできるように柔軟に対応することができます。
[メール登録実行ユーザ名]
メール登録を実行するChronoStarのユーザを指定します。
システムオプションを更新する前に起動していたクライアントは再起動するまで古いオプション設定で動作しますので問題が発生する可能性があります。オプション設定を実行する前に、サーバに接続しているクライアントをすべて終了させてください。

リムーバブル連携オプションがある場合

リムーバブル連携オプションがインストールされている場合、システムオプションウィンドウは次のようになります。

オプションを設定して[更新]または[OK]ボタンをクリックすると動作が反映されます。[更新]ボタンをクリックせずに[キャンセル]ボタンをクリックすれば変更は破棄されます。

[チェンジャ使用時、待ち状態でメディアをドライブから排出する]
チェンジャを使用しているとき、メディアがドライブに挿入されている状態で一定時間メディアにアクセスがなければドライブからメディアを排出します。
[待ち時間(分)]
排出までの待ち時間を分単位で設定します。
[夜間転送開始時間（時）]
夜間転送処理を開始する時間を設定します。
アクセスが少ない時間を設定してください。
[今すぐ夜間転送開始（時）
夜間転送開始時間に関係なく、直ちにメディアにデータを転送します。

パスワード

ローカルログインがONの場合、パスワードポリシーを適用することができます。

[パスワードの長さ]
ユーザー アカウントのパスワードに使用できる最小文字数を決定します。1 ～ 14 文字に設定するか、
文字数を 0 に設定してパスワードを不要にします。デフォルトではチェックされていません。
[複雑さの用件を満たす必要がある]
このポリシーが有効な場合、パスワードは次の最小要件を満たす必要があります。
ユーザーのアカウント名の全部または一部を使用しない。
長さは 6 文字以上にする。
次の 4 つのカテゴリのうち 3 つから文字を使う。
英大文字 (A ～ Z)
英小文字 (a ～ z)
10 進数の数字 (0 ～ 9)
アルファベット以外の文字 (!、$、#、% など)
要求する複雑さは、パスワードの変更時または作成時に必要です。デフォルトではチェックされていません。
[パスワードの有効期間]
パスワードを使用できる期間 (日数) を決定します。この期間を過ぎると、
システムから変更するよう要求されます。有効期間として 1 ～ 999 までの日数を指定するか、
日数を 0 に設定してパスワードの有効期限が切れないように指定します。デフォルトではチェックされていません。

［システム管理者ツールは、管理者権限のみ起動可能］
システム管理ツールを起動できるユーザを管理者権限があるユーザーだけに設定できます。
ただし管理者権限のユーザが存在しない場合は設定できません。デフォルトではチェックされていません。
アクセスが少ない時間を設定してください。
[今すぐ夜間転送開始（時）
夜間転送開始時間に関係なく、直ちにメディアにデータを転送します。


信頼性エージェント設定

4.9 信頼性エージェント設定

クロノスターでは登録ファイルを長期に渡って利用できることを保証する仕組みとして、信頼性エージェントと呼ばれるモジュールを用意しています。これは、フィルタエージェントおよびコンバータエージェントによって、登録されるファイルを制限することができる機能です。

[信頼性エージェント設定]では、フィルタ/コンバータの設定を行います。

信頼性エージェントの設定手順

  1. アドミンのメインウィンドウから、［信頼性エージェント設定］ボタンをクリックします
  2. ［追加］ボタンをクリックします

  3. [拡張子]、[バージョン]、[動作]、[コンバート先拡張子]をそれぞれ設定します。これらの項目は組み合わせによって設定が不要な場合はグレイアウトされます
  4. 項目を設定したら［OK］をクリックして設定します

設定可能なフィルタの種類

信頼性エージェントでは様々な設定を行うことができます。以下にその種類を説明します。

登録許可
指定した拡張子を持つファイルの登録を許可します。通常は［その他］="許可"としておくことで、個別に設定した拡張子以外は無条件で許可するように設定します。
警告許可
指定した拡張子を持つファイルが登録された場合に、管理者に許可されていない旨のメッセージを表示します。これは将来的に使用されなくなるフォーマットのファイルや、一般的でないアプリケーションのファイルが登録されたことをユーザに警告する目的で使用されます。
拒否
指定した拡張子を持つファイルが登録されようとした場合に、警告を表示して登録を拒否します。
登録時にコンバート
指定した拡張子を持つファイルが登録された場合に、警告を表示してコンバートダイアログを表示します。ユーザはコンバートして登録するか、登録をあきらめるかの選択を行います。部署単位で画像フォーマットを統一したり、使用するアプリケーションのバージョンを統一したりする場合に使用します。
[登録時にコンバート]を設定する場合、コンバート可能な組み合わせを設定するようにして下さい。現在のバージョンではコンバートできない組み合わせが設定された場合でも警告は発生しません。


メディア入出

4.10 メディア入出

このツールではオートチェンジャに関する操作を行います。可能な操作は以下のとおりです。

  • DVDメディア（またはその他のリムーバブルメディア）のオートチェンジャからの排出
  • オフラインメディアのオートチェンジャへの挿入
  • 転送状況の確認と操作

メディアの排出（オフライン化）

クロノスターではリムーバブルメディアにデータを転送し、そのメディアをオートチェンジャから排出した後でも検索やサムネイルの表示をすることができます。また、それらの排出されたメディアのファイルへの操作が必要になった場合、システムのメッセージに従ってメディアを挿入すれば、排出前と同じようにファイル操作をすることができます。この機能はオフライン管理と呼ばれます。

以下の手順でメディアをオフラインにします。

  1. アドミンのメインウィンドウから、[メディア入出]ボタンをクリックします。

  2. 取り出したいメディアを[棚状況]のリストから選択し、マウスの右クリックメニューから[取り出し(オフライン)]選択します。

  3. オートチェンジャからメディアが排出されますので、取り出して保管します。

オフラインメディアの挿入

クロノスターではオフラインのメディアに保存されているファイルも高速に検索やサムネイル表示をすることができますが、アプリケーションから開いたりローカルディスクに取り出したりする場合にはメディアをオートチェンジャに挿入する必要があります。オフラインメディアのオートチェンジャへの挿入は以下の手順で行います。

  1. 挿入したいオフラインメディアをオートチェンジャのメールスロットに挿入します。
  2. アドミンのメインウィンドウから、[メディア入出]ボタンをクリックします。
  3. 挿入したいオフラインメディアを選択し、マウスの右クリックメニューから[棚に挿入]を選択します。

  4. オートチェンジャが動作し、メディアが挿入されます。

転送状況の確認

[メディア転送状況]ウィンドウでは、メディア入出の他にファイルの一括転送状況の確認と転送のキャンセル操作をすることができます。

[通常処理]タブをクリックすると、現在一括転送が実行されている状況が表示されます。これは、ファイルを印刷したときのプリンタのキュー表示と同様のものです。

[夜間処理]タブをクリックすると、[一括転送]コマンドで夜間転送を指定されたファイルの一覧が表示されます。[通常処理]のファイル同様、キューの削除などの操作ができます。


アクセスログ情報

4.11 アクセスログ情報

このツールではクロノスターにアクセスしたログを閲覧します。

アクセスログの表示

クロノスターにアクセスしたログを表示します。

以下の手順でアクセスログを表示します。

  1. アドミンのメインウィンドウから、[アクセスログ情報]ボタンをクリックします。

  2. 表示したい期間を選択します。ただし最大1万件までの表示となります。

  3. アクセスログが表示されます。

表示の種類

ユーザ毎

ユーザ毎に実行した機能の回数を表示します。

ファイル毎

ファイル毎に実行した機能の回数を表示します。

履歴

クロノスターにアクセスした履歴を表示します。

操作メニュー

[ファイル]-[CSV出力]メニュー
現在表示しているデータをCSVに保存します｡
[表示]-[選択]-[ユーザ毎]メニュー
ユーザ毎に実行した機能の回数を表示します。
[表示]-[選択]-[ファイル毎]メニュー
ファイル毎に実行した機能の回数を表示します。
[表示]-[選択]-[履歴]メニュー
クロノスターにアクセスした履歴を表示します。
[表示]-[選択]-[表示期間]メニュー
アクセスを表示する期間を設定します。
[表示]-[選択]-[列の選択]メニュー
[ユーザ毎]、[ファイル毎]の時に、表示する項目を選択します。

[表示]-[ログイン情報等を表示しない]メニュー
表示が履歴の場合、履歴にログイン情報等を表示しません｡
[表示]-[最新の情報に更新]メニュー
最新の情報に更新します｡


フォルダ監視設定

4.12 フォルダ監視設定

クロノスターでは、簡単な登録する手段として，サーバ上のフォルダを監視し、そこにファイルが保存されたときに登録することができます。
フォルダ監視機能では、ファイルは指定した共有ワークフォルダ内に保存されます。

本章では、この「フォルダ監視」機能を設定する方法について説明します。

フォルダ監視設定の起動

フォルダ監視設定は、「スタート」メニューより「フォルダ監視設定」を起動します。

監視フォルダの設定

メイン画面では、今まで設定した項目の一覧が表示されます。
追加操作を行う場合は、「追加」ボタンを、編集操作を行う場合は「プロパティ」ボタンをクリックします。

監視フォルダは最大１０件まで設定できます。

「追加」ボタンをクリックすると、フォルダ監視設定が表示されます。

設定する項目は次のとおりです。
項目名 | 説明
プロファイル名 | 設定に名前をつけます。 メイン画面で表示されます。
ユーザ名 | 登録を実行するユーザ名です。 ローカルログインを使用しない場合は、Windowsのユーザ名を入力してください。（ドメイン名は不要です） ローカルログインを使用する場合は、ChronoStarに登録されているユーザ名を指定してください。
パスワード | パスワードを入力します。
パスワード確認 | 確認のため，再度入力します。
フォルダ | 監視を行うフォルダ名です。「参照」ボタンを押して、フォルダを指定します。 監視するフォルダはサーバ上のフォルダを指定してください。 ネットワークフォルダは指定できません。
ChronoStarへの登録先 | ChronoStarへ登録する先である共有ワークフォルダを指定します。 「\」で区切ることにより、下位階層まで指定することができます。

監視設定したフォルダを共有フォルダに指定すると、ネットワーク上のほかのコンピュータから登録ができます。
監視設定したフォルダをWeb共有フォルダ（WebDAV）に設定すると、HTTPしか許可されていない部門間でファイル登録ができます。
スキャナや、複合機に共有フォルダへのファイル出力機能がある場合、出力先を監視フォルダに設定することで、直接ChronoStarに登録することができます。
ChronoStar側の登録ワークフォルダに、メール通知設定を行うと、登録されたと同時にメールで通知することができます。

１）登録後、ファイルは登録用フォルダより削除されます。
２）登録用フォルダ内のサブフォルダにファイルを登録してもChronoStarには登録されません。


ＣＳＶ登録

4.12 CSV登録ツール

CSV登録ツールは、複数のファイルをあらかじめ用意した設定ファイルを元に、バッチ的に登録を行うツールです。
旧システムからの移行や、大量にデータを登録する場合に役に立ちます。

1. 基本操作

2. 詳細設定

3. 自動実行


CSV登録ツール:基本設定

4.13 1. 基本操作

ツールの起動

スタートメニューより、「ＣＳＶ登録」を選択して起動します。

サーバの選択

サーバはChronosを選択します。

登録情報ファイルの指定

登録するCSVファイルの各項目がクロノスターで管理する属性のどの項目に対応するかを指定するための｢登録情報ファイル｣を作成します。既に作成している場合は入力欄にファイル名を記入するか［．．．］ボタンを使用してファイルを選択します。はじめて登録する場合は［新規作成］ボタンをクリックして作成作業を行います。

登録情報ファイルの新規作成

はじめて登録作業を行う場合は［新規作成］ボタンをクリックして登録するCSVの各項目に対応するクロノスターの属性項目を選択します。

任意の属性グループから項目を選択し［追加］ボタンをクリックします。［上へ］［下へ］ボタンで位置を調整できます。CSVファイルの項目記述順と項目数に合うように設定してください。［OK］ボタンをクリックし任意のファイル名を付けて保存します。

登録CSVファイルの指定

登録CSVファイルを指定します。入力欄にファイル名を入力するか［．．．］ボタンで参照して設定します。

CSVファイルは左端にファイル名を記述し、2項目目以降に登録する属性を記入します。ファイル名にはパス名を含むこともできます。パス名がある場合は、そのパスにあるファイルを最優先で使用します。パス名が省略された場合は、次の手順で設定する｢登録データの保管場所｣の設定を使用します。

設定内容の確認

｢テスト表示｣ボタンをクリックし設定内容を確認することができます。先頭の5行が表示されます。登録情報とデータ内容が一致していない時は警告します。その場合、そのまま強制登録もできますが、エラー表示している項目は登録されませんのでご注意ください。

登録データ保管場所の指定

ファイルの保管場所ディレクトリを指定します。｢指定フォルダ以下にあるサブフォルダ内も検索対象とする。｣にチェックを入れた場合は指定されたディレクトリ以下のフォルダを追跡して登録ファイルを探します。チェックをしない場合、指定フォルダ内にファイルが見つからなかった場合は追跡検索を実行せずに登録をスキップします。

エラー出力ファイルの指定

ファイルが見つからなくスキップされた行やその他エラーが発生した行を別ファイルに保存したい場合は、そのファイル名を指定しておきます。特に指定しなくても登録は実行できます。ファイルが見つからなかったものだけを再度登録実行する場合のデータファイルとして利用できます。

登録実行

以下のオプション設定を選択して｢登録実行｣をクリックします。

各オプションの説明は下記のとおりです。
同名ファイルは別ファイルとして登録する。
同名ファイルが既に存在する場合は別のファイルとして登録します。ただしクロノスター管理者ツールで設定されている同名禁止設定状況によっては登録できない場合があります。
同名ファイルはスキップする。
同名ファイルが既に存在する場合は登録しません。エラー出力ファイルが指定されている場合は、そのファイルに該当行を出力します。スキップが発生した場合にそれをエラーとして扱うかどうかは［詳細設定］で変更できます。
同名ファイルは上書き更新する
同名ファイルが既に存在する場合は、そのファイルを差し替えると同時に属性を更新します。
同名ファイルが存在しない場合は新規登録されます。属性更新は［既存の属性をすべて削除してから上書きする。］のチェックの状態により動作が変わります。
チェックされた場合は既存の属性情報をすべて削除してから再登録しますが、チェックされていない場合は既存の属性への追記更新となります。
［更新されたファイルのみ］にチェックされている場合は登録済みのファイルと登録ファイルの更新日付を比較し、登録ファイルが新しい場合のみファイルの差し替えを実行しますので登録に必要な時間を節約できます。
ファイルの差し替えがない場合でも属性の更新は実施します。
他のユーザが編集中のファイルは更新できません。
属性情報の更新のみ行う。
属性情報の更新のみ行い、ファイルの差し替えは実行しません。［既存の属性をすべて削除してから上書きする。］はこのモードでも有効です。属性のみの更新でいい場合はファイルの差し替えが発生しない分、登録時間が大幅に短縮できます。
ダミーファイルの差し替えを行う。
［詳細設定］によりダミー画像を指定して登録されたファイルのみ差し替えを実行します。ダミー画像でないファイルは登録をスキップします。ダミー画像を使用して登録されているファイルが正式なファイルになった場合に効率良く差し替えができます。


CSV登録ツール：詳細設定

4.13 2.詳細設定

[詳細設定］ボタンをクリックすると登録動作を詳細に設定できる画面が表示されます。

ファイルが見つからない場合はタイトル登録とする。
登録ファイルが見つからない場合はエラーとせずに属性情報のみ登録(タイトル登録)します。
タイトル登録に使用する画像を指定する。
上の設定でタイトル登録となったファイルに画像を割り当てることができます。JPEGもしくはBMP形式のファイルを指定します。このモードで登録されたファイルは、後日［ダミーファイルの差し替えを行う。］モードで効率良く差し替えができます。
同名ファイルのスキップをエラーとする。
同名ファイルが存在した場合にスキップされるモードで動作している時にそれをエラーと扱うかどうかを設定できます。
ファイル名の変換
登録後のファイル名を任意の書式に変換できます。CSVでは統一されていない書式をデータベース上では統一したい場合に使用します。
属性値の変換
登録後の属性値を任意の書式に変換できます。CSVでは統一されていない書式をデータベース上では統一したい場合に使用します。
前処理フィルターを使用する。
登録データのCSVを前処理するフィルタープログラムを設定できます。フィルタープログラムの詳細な仕様については弊社までお問い合わせください。以下のような機能を追加できます。
  • 登録CSVデータへの列追加、列削除、任意の列の結合、変換
  • 登録と同時に自動採番
  • 改訂履歴の作成
  • 承認処理
  • サムネイルの差し替え
  • リムーバブルメディアへの転送
リンクファイルを使用する。

登録終了後にリンクを設定することができます。1列目にリンク元ファイル、2列目にリンク先ファイル(”リンク元ファイル”,”リンク先ファイル”)を書き並べたCSVファイルを設定します。ファイル名の変わりに”図番”などファイルを一意に特定できる属性を設定することもできます。その場合は［リンクに使用する列］からその属性項目を選択します。［既存のリンクをすべて削除してから登録する。］をチェックした場合はリンク登録前に既存のリンクを一旦すべて削除してから登録します。そうでない場合は現在のリンクに追加登録します。

登録終了後に登録元のファイルを削除する。
登録終了後に登録元のファイルを削除することができます。
区切り文字
CSVの区切り文字を選択できます。カンマ、タブ、セミコロンから選択できます。その他を設定して任意の文字を設定することもできます。登録情報ファイルと登録CSVファイルの双方を、ここで設定された区切り文字で読み込みます。


CSV登録ツール：自動実行

4.13 3.自動実行

コマンドライン引数

CSVEntry.exeに引数を与えて実行することで定期的に自動実行するような使用方法に適用できます。

CSVEntry.exe <サーバ名> <環境ファイル>

環境ファイル

第一引数にはサーバ名を指定します。これはメイン画面のサーバ設定欄から選択できるサーバ名です。通常は｢chronos｣です。環境ファイル名は動作設定を記述したテキストファイルです。省略した場合は最後に動作したモードで動作します。
以下のような内容を環境ファイルとして定義できます。

HeaderFile = C:\My Documents\CSVEntry\店舗登録ヘッダ.csv
DataFile = C:\My Documents\CSVEntry\店舗データ.csv
DataDir = C:\My Documents
ErrorFile =
OptionEntryMode = 3
OptionEntryOldAttr = TRUE
OptionEntryCompMTime = TRUE
OptionTitleEntry = TRUE
OptionDummyImage = TRUE
OptionDummyImageFile = = C:\My Documents\Dummy.jpg
OptionSkipError = FALSE
OptionFileConvert = 9
OptionAttrConvert = 9
OptionFilter = TRUE
OptionFiltername = = C:\My Documents\Filter.exe
OptionLink = TRUE
OptionLinkFile = = C:\My Documents\Link.csv
OptionLinkColumn = 1
OptionLinkOldKill = FALSE
OptionDelSourceFile = FALSE
OptionSeparator = ,

環境ファイルの値

環境設定ファイル内の値は下記のとおりです。
OptionEntryMode

0 同名ファイルは別ファイルとして登録する。
1 同名ファイルはスキップする。
2 同名ファイルは上書き更新する。
3 属性情報の更新のみ行う。
4 ダミーファイルの差し替えを行う。
OptionFileConvert,OptionAttrConvert
8 大文字化
4 小文字化
2 全角化
1 半角化


こんなときには(FAQ)

5. こんなときには(FAQ)

クロノスターをお使いいただく上で、知っておいていただくと便利なことやよくご質問をいただくことなどをご説明します。

  • 5.1 よく聞かれる質問と答え（ＦＡＱ）
    • - クライアント全般
    • - ファイル操作
    • - ツール
    • - 検索
    • - サーバ全般
    • - 属性設定
    • - 領域作成
    • - 承認ルート作成
    • - 信頼性エージェント
  • 5.2 制限事項
    • - クライアントの制限事項
    • - サーバの制限事項


よく聞かれる質問と答え（ＦＡＱ）

5.1 よく聞かれる質問と答え（ＦＡＱ）

よく聞かれる質問と答えについて説明します。

クライアント全般

  • ブック・スライダがメニューに表示されません。
  • ウィンドウ左下の［検索］と［Wizard］はどうやって使うのですか？
  • フォルダツリーの［+］記号が消えるときがあります。
  • フォルダツリーの下の領域の意味がわかりません。
  • ワークフォルダやバーチャルフォルダの[個人]の下に作成したフォルダを[共有]の下に移動できませんか？

ファイル操作

  • ワークフォルダのファイルの消去について。
  • サムネイルがアイコンになってしまう。
  • 登録できるファイルの最大数は？
  • ドラッグ＆ドロップで登録できないときがあります。
  • 属性値は最大何文字まで入力できますか？
  • 属性表示ウィンドウでなぜ[ファイル]グループだけ青いのですか？

ツール

  • [一括転送]コマンドで［夜間］を指定するとどうなるのですか？
  • [承認依頼]で承認ルートを選択しているのにエラーになります。
  • 複数のファイルを選択して承認依頼するとどうなりますか？
  • [承認状況]で誤って[削除]を押してしまいました。状況を確認する方法はありますか？
  • [チェックアウト状況]でチェックアウトされているはずのファイルが表示されません。

検索

  • 登録したファイルが全文検索で見つかりません
  • 個人バーチャルフォルダの下に、［検索結果］フォルダがたくさんあって邪魔です
  • 似ている画像なのに見つかりません

サーバ全般

  • ボタンが無効になっていて選択できません

属性設定

  • あるグループに設定した権限を別のグループにコピーできますか？
  • 設定したグループがツリーに表示されません。

領域作成

  • HDDを増設したいのですが、データを移行できますか？
  • [キャッシュ領域]の意味がわかりません。
  • 誤って領域を作成してしまいました。

承認グループ作成

  • 承認ユーザにNTのグループを指定できませんか？
  • 選択可能ユーザが表示されません。

信頼性エージェント

  • 登録を拒否したいファイルの拡張子が表示されません
  • [警告許可]を設定するとどうなりますか？

よく聞かれる質問と答えの最新情報はhttp://www.chronostar.jp/をご覧下さい。


制限事項

5.2 制限事項

この章では、クロノスターの既知の問題点について説明します。

クライアントの制限事項

  • 日付型の属性項目をシステムフォルダに割り当てると正しく表示されない
  • 検索パネルの高さが十分に開いていない状態で大量の属性項目を設定すると異常終了する
  • 日付型の属性項目に日付として正しくない値が入力できる
  • アプリケーションの関連付けでJPEGファイルをPhotoShopに関連付けていると、[ファイル]-[印刷]が動作しない
  • フィルタのチェックは登録前には行わない
  • チェックアウト中のファイルの名前を変更するとチェックインできない
  • [ファイル]-[印刷]でプリンタの設定を変更しても有効にならない（用紙サイズ・割り付け）
  • ３D表示の領域にドラッグ&ドロップ登録できない
  • 画面の色数が24ビット未満だと類似画像検索の結果がおかしい
  • [最新の情報に更新]コマンドではフォルダ情報は更新されない
  • 半角256文字以上の長さのフォルダを作成すると異常終了する
  • 承認中のファイルを選択して承認依頼が実行できる
  • フォルダの名前変更エラーのダイアログでマウスが効かない
  • 属性表示で[属性編集]メニューを表示してCtrl+Aを押すとフリーズする
  • [一括転送]実行中のファイルをマルチイメージ表示すると表示が乱れることがある
  • チェンジャやオフラインを示すファイルの色は自動的に更新されない
  • マルチイメージ表示では32767行以上は表示できない
  • 転送予約中のファイルをチェックアウトした場合は、HDD上に戻さないとチェックインできない
  • ファイルフォーマット変換が中止できない
  • ウィンドウが画面外に表示される
  • 日付属性のソート順が逆になっている
  • ３D表示の前後関係が乱れる
  • パスに空白文字が含まれるファイルは[送る]メニューから登録できない
  • 検索条件に不正な値を設定してもエラーが表示されない場合がある
  • 属性表示で右クリックメニューが表示されない
  • 大量の検索結果を表示するとスクロールが極端に遅くなることがある
  • [チェックイン]ウィンドウを開いたままもう一度チェックインを実行するとおかしな動作をする
  • CSV出力で、読取専用ファイルを上書きしようとすると異常終了する
  • 日付を一致で検索すると結果が表示されない
  • 登録時コンバートを設定している場合に、コンバートをキャンセルすると結果表示がおかしい
  • 数値型の「*」検索ができない
  • ファイルをチェックインすると、[作成日時]が更新される
  • [承認依頼]で承認表題や承認者への連絡事項に長い文字列を入力すると異常終了する
  • ワークフォルダのファイルを分岐してもワークフォルダには現れない

サーバの制限事項

  • フィルタ設定で実行不可能な組み合わせが設定できる
  • 日付型の属性項目に日付でない固定入力値を設定できる
  • サーバのキャッシュ領域が不足すると、DVD上のファイルのサムネイルが表示されないことがある
  • サーバでクロノスター用に設定されたODBCの設定を変更するとデータを破壊する恐れがある
  • クロノスターのツールを使用せずにオートチェンジャのメディアの出し入れを行うとデータを破壊する恐れがある
  • DVDオートチェンジャで複数のメディアを挿入する際、挿入完了を待たずに次のメディアを挿入すると制御不能になる
  • 領域作成で間違って作成した領域を削除する方法がない
  • 複数段の属性項目では、改行コードも文字の長さにカウントされる

制限事項の最新情報はhttp://www.chronostar.jp/をご覧下さい。


クライアントの制限事項

最終更新日：2000/10/16

日付型の属性項目をシステムフォルダに割り当てると正しく表示されない

ChronoStarでは日付型の属性項目は秒単位まで厳密に比較を行います。このため、属性値として 2000/01/01 などの日付を設定してシステムフォルダに表示しても、2000/01/01 の値を持つファイルが表示されません。システムフォルダには日付型の属性項目を設定しないで下さい。

検索パネルの高さが十分に開いていない状態で大量の属性項目を設定すると異常終了する

クロノスターのメインウィンドウの高さを極端に狭めて検索を実行すると、検索パネルの表示が乱れることがあります。この状態で検索条件を大量に検索パネルにドロップすると、クライアントが異常終了することがありますのでこのような操作は行わないようにして下さい。

日付型の属性項目に日付として正しくない値が入力できる

日付型の属性項目に日付ではない文字列が設定できます。特に深刻な状況は発生しませんが、日付による検索が正しく動作しないなどの不具合があります。

アプリケーションの関連付けでJPEGファイルをPhotoShopに関連付けていると、[ファイル]-[印刷]が動作しない

クロノスターの[印刷]はエクスプローラでファイルを選択して[印刷]メニューを実行した場合と同じ動作を行います。エクスプローラから印刷できないファイルはクロノスターでも印刷できません。

フィルタのチェックは登録前には行わない

登録ファイルにコンバート対象ファイルが含まれる場合、登録処理を実行した後にコンバート登録を実行するという手順になります。

チェックアウト中のファイルの名前を変更するとチェックインできない

チェックアウト中にクロノスターのファイル名が変更できますが、この操作を行うとチェックインができなくなります。このような場合は一旦チェックアウトを取り消して再度チェックアウトを実行してください。

[ファイル]-[印刷]でプリンタの設定を変更しても有効にならない（用紙サイズ・割り付け）

クロノスターの[印刷]コマンドで表示される印刷ダイアログから[オプション]でプリンタの設定を変更した場合に変更が反映されない場合があります。

３D表示の領域にドラッグ&ドロップ登録できない

３D表示領域へのファイルのドラッグ&ドロップはサポートしていません。

画面の色数を256色にすると表示が乱れる

クロノスターは中間色を多用しているため、画面の色数が256色以下だと非常に見にくい表示になります。

画面の色数が24ビット未満だと類似画像検索の結果がおかしい

類似画像検索のための画像の特長抽出プログラムの制限で、画面の色数が24ビット未満の場合に類似画像が正しく検索されないことがあります。このため、特長抽出プログラムを実行するマシンの画面の色数は24ビット以上に設定してください。

特長抽出プログラムは通常サーバ上で実行されますが、クライアントのオプションで[登録直後に画像検索対象]をチェックしているとクライアント上で実行されます。

[最新の情報に更新]コマンドではフォルダ情報は更新されない

[最新の情報に更新]コマンドではフォルダ情報は更新されませんので、例えばクライアント起動中に別のクライアントによってフォルダが作成されたり削除されたりした場合に、動作がおかしくなる事があります。

半角256文字以上の長さのフォルダを作成すると異常終了する

フォルダ名を半角で256文字以上に設定すると、クライアントが異常終了します。この場合、フォルダ名は変更前の名前のままになります。

承認中のファイルを選択して承認依頼が実行できる

"承認待ち"状態のファイルを選択して[承認依頼]コマンドを実行することができます。この場合、最後に実行された承認動作が有効になります。

フォルダの名前変更エラーのダイアログでマウスが効かない

フォルダの名前変更でエラーが発生した場合、エラーダイアログの[OK]ボタンがマウスでクリックできない現象があります。このときはEnterキーでダイアログを閉じてください。

属性表示で[属性編集]メニューを表示してCtrl+Aを押すとフリーズする

属性表示で[属性編集]メニューをポップアップした状態でCtrl+Aを押すとフリーズすることがあります。現在回避する方法はありませんので、この動作は行わないようにして下さい。

バーチャルフォルダの名前変更が[Enter]キーで確定できない

バーチャルフォルダで名前変更の際、変更を確定するためにEnterキーを押しても名前変更が完了しません。マウスでフォルダ以外の場所をクリックして名前の変更を確定してください。

ワークエリアでチェックアウトしたファイルは[最新の情報に更新]を実行するまでチェックインできない

ワークエリアのファイルをチェックアウトした場合、ファイルの状態が即座に変更されません。ワークエリアでファイルの状態を変更した場合は明示的に[最新の情報に更新]コマンドを実行して状態を更新してください。

[一括転送]でDVD->HDDの時、履歴ファイルは転送されない

DVDに一括転送を行うと履歴ファイルも一緒に転送されますが、DVDからHDDに一括転送でファイルを戻す際には履歴ファイルは転送されません。

[一括転送]実行中のファイルをマルチイメージ表示すると表示が乱れることがある

一括転送は別プロセスで動作するため、クライアントの持っている情報とファイルの位置が一時的に食い違うことがあります。[最新の情報に更新]コマンドを実行すれば正常に表示されます。

チェンジャやオフラインを示すファイルの色は自動的に更新されない

一括転送は別プロセスで動作するため、クライアントの持っている情報とファイルの位置が一時的に食い違うことがあります。[最新の情報に更新]コマンドを実行すれば正常に表示されます。

マルチイメージ表示では32767行以上は表示できない

仕様です。

転送予約中のファイルをチェックアウトした場合は、HDD上に戻さないとチェックインできない

[一括転送]コマンドでリムーバブルメディアに転送予約されているファイルもチェックアウトすることができます。それらのファイルをチェックインする際は、[一括転送]コマンドでHDD上に転送してからチェックインを実行してください。

ファイルフォーマット変換が中止できない

[ファイルフォーマット変換]コマンドは途中でキャンセルすることができません。

ウィンドウが画面外に表示される

画面のサイズを変更した場合に、クロノスターのウィンドウが画面外に表示される場合があります。ウィンドウが出ているはずなのに画面にウィンドウが表示されないといった状況に陥った場合は以下の手順でウィンドウを画面に収まるように移動してください。

  1. ウィンドウズのタスクバーをマウスで右クリックし、ポップアップメニューを表示
  2. ポップアップメニューから、[重ねて表示]/[左右に並べて表示]/[上下に並べて表示]のいずれかを選択

日付属性のソート順が逆になっている

ウィンドウズの設定で、日付の表示形式を[午前12時]のように午前/午後の形式に設定している環境では、クロノスターのリスト表示で日付のソート順がおかしくなります。

３D表示の前後関係が乱れる

ディスプレイドライバとの相性の関係で、スライダー表示やブック表示を行った際に３D空間の前後関係が逆になることがあります。その場合、DirectXの３Dレンダリングの設定をソフトウェアレンダリングに設定することで回避することができる場合があります。

パスに空白文字が含まれるファイルは[送る]メニューから登録できない

登録モジュール(ChronoEntry.exe)は起動パラメータにファイル名を受け付けるため、エクスプローラの[送る]メニューにショートカットを登録することで直接登録を行う設定が可能ですが、[送る]の対象となるファイルのパスやファイル名に空白文字が含まれる場合には正常に登録できません。

検索条件に不正な値を設定してもエラーが表示されない場合がある

[属性検索]で、[ファイル検索/全文検索]の[ファイルの状態]には属性値を手入力することができますが、手入力で不正な値が入力されてもエラーが表示されないことがあります。[ファイルの状態]で検索する場合にはなるべく属性値を手入力しないでください。

属性表示で右クリックメニューが表示されない

[属性表示]の際、サムネイルの領域でマウスを右クリックするとポップアップメニューが表示されてファイル操作が行えますが、マルチサムネイルを表示した直後はポップアップメニューが出なくなります。その場合には[拡大/縮小]を行う虫眼鏡のアイコンをクリックしてください。

大量の検索結果を表示するとスクロールが極端に遅くなることがある

Windows9x系のOSでは、検索結果に数千から数万件のファイルが表示されると、スクロールが極端に遅くなることがあります。このような環境では、オプションで[検索結果を切り捨てる]を500程度の値に設定してお使いください。

チェックイン]ウィンドウを開いたままもう一度チェックインを実行するとおかしな動作をする

[チェックイン]のウィンドウを開いたままで、同じファイルを選択して[チェックイン]コマンドを実行すると、同じファイルを続けてチェックインするような動作になって異常動作となります。

CSV出力で、読取専用ファイルを上書きしようとすると異常終了する

CSV出力で、[出力先]に既存の読取専用ファイルを指定すると、[OK]ボタンをクリックした後に異常終了します。[出力先]には読取専用ファイルを指定しないでください。

日付を一致で検索すると結果が表示されない

[属性検索]で、[ファイル検索/全文検索]の[作成日]などの日付項目に対し、属性値として「2000/01/01」などの日付を設定すると、一致するはずのファイルが見つからないことがあります。これは、属性値が「2000/01/01 0:00」と時間付きで解釈されるためで、この場合、「2000/01/01」以上、「2000/01/02」未満のAND検索を行うことで目的の日付のファイルを検索することができます。

コンバートを設定している場合に、コンバートをキャンセルすると結果表示がおかしい

[システム管理ツール]の[信頼性エージェント設定]で、[登録時コンバート]と指定された拡張子のファイルが登録された場合、登録時に[コンバート]ダイアログが表示されますが、このダイアログで[キャンセル]を選択して登録を中止しても、登録が完了されたようなメッセージが表示されます。

数値型の「*」検索ができない

属性検索で属性値としてワイルドカードの「*」を入力すると、その属性項目に何らかの値が設定されているファイルが検索されますが、数値型の属性項目などでは検索できないことがあります。

ファイルをチェックインすると、[作成日時]が更新される

クロノスターではファイルの[作成日時][更新日時][アクセス日時]を記憶していますが、ファイルの作成日時は[チェックアウト]->[チェックイン]の操作で更新されます。これはサーバとクライアント間でファイルのコピーが行われているためで、作成日時を記憶しておきたい場合には[属性項目]として入力するなどの運用を行ってください。

[承認依頼]で承認表題や承認者への連絡事項に長い文字列を入力すると異常終了する

[承認依頼]コマンドで[承認表題]に半角で65文字以上または[承認者への連絡事項]に半角で256文字以上を入力して[開始]ボタンをクリックすると異常終了します。

ワークフォルダのファイルを分岐してもワークフォルダには現れない

[履歴表示]で[分岐]コマンドを実行した場合、生成されたファイルは分岐元のファイルと同じ属性を持ちますが、分岐元が所属するワークフォルダへは追加されません。従って、ワークフォルダからファイルを選択して[分岐]の動作を行う場合には、ファイルを見失わないように注意してください。

一覧に戻る


サーバの制限事項

最終更新日：2000/10/16

バージョン1.0以降

フィルタ設定で実行不可能な組み合わせが設定できる

信頼性エージェント設定で[登録時コンバート]フィルタの追加を行う際、プログラムでは変換可能な組み合わせをチェックしていません。このため、文書ファイルを画像ファイルにコンバートするといった設定を行うことができますが、これは正しく動作しません。

[登録時コンバート]フィルタはクライアントで[ファイルフォーマット変換]コマンドが成功する組み合わせに設定してください。

日付型の属性項目に日付でない固定入力値を設定できる

属性設定ツールで属性値を入力する際、プログラムでは属性の型のチェックを行っていません。設定は慎重に行ってください。

サーバのキャッシュ領域が不足すると、DVD上のファイルのサムネイルが表示されないことがある

キャッシュ領域はDVDに転送したファイルのサムネイルを保存する領域ですので、この領域が不足するとサムネイルが表示されないことがあります。キャッシュ領域が不足した場合には領域設定ツールで新たに領域を追加してください。

サーバでクロノスター用に設定されたODBCの設定を変更するとデータを破壊する恐れがある

クロノスターのサーバ上で動作するプログラムには、サーバのODBC設定からサーバ名を取得して動作するものがあります。このため、ODBCの設定を別のサーバに変更したときに、そのサーバのデータを不正に更新する可能性があります。クロノスター用に設定されたサーバのODBCの設定は変更しないで下さい。

クロノスターのツールを使用せずにオートチェンジャのメディアの出し入れを行うとデータを破壊する恐れがある

チェンジャ連携機能を使用しているシステムの場合、オートチェンジャの動作はクロノスターによって制御されます。このため、クロノスターを経由せずに直接オートチェンジャの状態を変更すると、クロノスターがオートチェンジャを制御できない状況が発生します。従って、オートチェンジャのメディアの出し入れ等の操作はクロノスターのツールを使って行うようにして下さい。

DVDオートチェンジャで複数のメディアを挿入する際、挿入完了を待たずに次のメディアを挿入すると制御不能になる

DVDオートチェンジャで複数のメディアを挿入する場合、オートチェンジャがメディア挿入待ちになったことを確認してからメディアを挿入するようにして下さい。クボタ製DVDオートチェンジャ（DJ-20等）の場合は「ピピッ」と音が鳴ったのを確認してください。

領域作成で間違って作成した領域を削除する方法がない

現在の領域作成ツールでは、作成した領域を削除する機能がありません。このため、領域作成ツールは慎重に使用してください。バージョン1.1以では、作成直後であれば削除できます。

複数段の属性項目では、改行コードも文字の長さにカウントされる

属性設定ツールで属性項目の[詳細設定]から[段数]を2以上に指定した場合属性値を複数行入力することができますが、このとき、改行１つにつき半角2文字分の文字列が追加されます。このため、[長さ]で設定した文字数だけの属性値が入力できないことがあります。複数段の属性項目を作成する場合は、[長さ]を長めに設定してください。

一覧に戻る


ブック・スライダがメニューに表示されません

最終更新日：2000年9月26日
文書番号：CH1000000001

概要

この資料は３D表示に関する説明です。

詳細

ブック表示・スライダ表示にはDirectXバージョン5.0以降の環境が必要です。このため、WindowsNT4.0などのOS上ではクロノスターの３D表示は無効になり、メニューが非表示になります。

備考

  • システムカラー16Bit以下の表示モードでは3Dは動作しません。
  • OSにインストールしたアプリケーションや起動中のアプリケーションの影響で3Dの動作にコマ落ちが頻繁に発生する場合があります。

一覧に戻る


ウィンドウ左下の［検索］と［Wizard］はどうやって使うのですか？

最終更新日：2000年9月26日
文書番号：CH1000000002

概要

この資料はメインウィンドウの内容について説明しています。

詳細

メインウィンドウの右下にある[検索]と[WIZARD]は将来のバージョンのために用意されており、バージョン1では使用されません。

備考

一覧に戻る


フォルダツリーの［+］記号が消えるときがあります

最終更新日：2000年9月26日
文書番号：CH1000000003

概要

この資料はメインウィンドウの表示について説明しています。

詳細

クロノスターではフォルダの情報を実行時にデータベースから取得していますが、高速化のために最低限必要な情報のみを取得するように設計されています。このため、あるノードを展開すると子供のノードがあるかどうかにかかわらず常に[+]記号を表示し、実際に子供のノードを表示しようとしたときに子供のノードがあるかどうかの情報を取得して表示を更新します。

従って子供のノードが存在しないノードを展開しようとしたときに[+]記号が消えたような動作になります。

備考

一覧に戻る


フォルダツリーの下の領域の意味がわかりません

最終更新日：2000年9月26日
文書番号：CH1000000004

概要

この資料はメインウィンドウの表示に関する説明です。

詳細

フォルダツリーの下の領域はワークエリアと呼ばれる領域で、ここにはワークフォルダの[個人ワーク]->[Work Area]の内容が常に表示されます。

ワークエリアを使うことで以下の利点があります。

  1. 起動直後にD&D登録ができる
  2. 起動直後にファイルを選択できる

備考

一覧に戻る


ワークフォルダやバーチャルフォルダの[個人]の下に作成したフォルダを[共有]の下に移動できませんか？

最終更新日：2000年9月26日
文書番号：CH1000000018

概要

この資料はフォルダ操作に関する説明です。

詳細

直接移動はできませんが、バーチャルフォルダの場合は以下の操作で同じことができます。
個人］の下のフォルダ上で右ボタンをプレスし「コピー」を選択し、［共有］フォルダに貼り付けます。さらに、元のフォルダを削除します。

備考

一覧に戻る


ワークフォルダのファイルの消去について

最終更新日：2000年9月26日
文書番号：CH1000010005

概要

この資料はファイルの削除に関する説明です。

詳細

一度ワークフォルダやワークエリアに送ったファイルを、ワークフォルダには表示しないが、実体ファイルを削除したくない場合には、[ファイル]－[送る]－[ワークフォルダから外す]コマンドを実行すれば、実体は削除されません。

備考

一覧に戻る


サムネイルがアイコンになってしまう

最終更新日：2000年9月26日
文書番号：CH1000010006

概要

この資料は登録に関する説明です。

詳細

クロノスターではWindowsのOLEという技術を使い、登録ファイルのサムネイルをそのファイルに関連付けられたアプリケーションに作成させています。このため、関連付けられたアプリケーションがOLEｌに対応していない場合、特別に対応したアドインを追加しない限り登録時にサムネイルが生成されません。なお画像ファイル（BMP,JPG,TIFF,…）はクロノスター内部でサムネイルを生成するため、アプリケーションの関連付けに関わらずサムネイルが作成されます。

備考

一覧に戻る


登録できるファイルの最大数は？

最終更新日：2000年9月26日
文書番号：CH1000010007

概要

この資料は登録に関する説明です。

詳細

登録されるファイルの平均のサイズに依存します。

平均ファイルサイズをNKB、クロノスターのデータ領域をVGBとすると以下の式が目安になります。

V×1,024×1,024÷(N＋60)

ドキュメント中心として、平均200Kバイトならば、クロノスターが付加する情報が60K程度となり20GBのディスクがクロノスターの領域ならば、約80,000 ファイルが格納できます。1ファイルが1メガあるならば約20,000ファイルとなります。

備考

一覧に戻る


ドラッグ＆ドロップで登録できないときがあります

最終更新日：2002年2月4日
文書番号：CH1000010008

概要

この資料は登録に関する説明です。

詳細

以下のフォルダにはドラッグ&ドロップで登録できません。

  • すべてのフォルダの１階層目
  • 書き込み権の与えられていない属性グループのシステムフォルダ。書き込み権のない場合は青いロックがフォルダに表示されます。

３D表示にはドラッグ&ドロップで登録できません。

一覧に戻る


属性値は最大何文字まで入力できますか？

最終更新日：2000年9月26日
文書番号：CH1000010009

概要

この資料は登録に関する説明です。

詳細

文字型の属性項目に設定できる属性値は半角で255文字までです。

備考

バージョン1.1からシステム管理ツールを使って文字列の長さを制限することができます。

一覧に戻る


属性表示ウィンドウでなぜ[ファイル]グループだけ青いのですか？

最終更新日：2000年9月26日
文書番号：CH1000010019

概要

この資料は属性表示に関する説明です。

詳細

[ファイル]属性グループは通常の属性グループと異なり、ファイルから情報を取得してクロノスターが自動的に設定する属性でユーザが編集することができません。このため、他の属性グループと区別する目的で表示する色を変更しています。

備考

一覧に戻る


[一括転送]コマンドで［夜間］を指定するとどうなるのですか？

最終更新日：2000年9月26日
文書番号：CH1000020010

概要

この資料は一括転送に関する説明です。

詳細

[夜間]の指定はオートチェンジャの転送速度の遅さを補うために用意されており、この項目を指定すると選択されたファイルは転送予約状態となり、管理者の設定した時間帯にまとめて転送が行われます。

従って管理者が昼間に一括転送を設定していた場合には、[夜間]を指定しても昼間に転送が行われることになります。

備考

一覧に戻る


[承認依頼]で承認ルートを選択しているのにエラーになります

最終更新日：2000年9月26日
文書番号：CH1000020011

概要

この資料は承認に関する説明です。

詳細

[承認依頼]ウィンドウでは[承認ルート]のツリーの2階層目を選択してください。

承認ルートは階層構造になっており、[承認依頼]ウィンドウの[承認ルート]欄に表示されるツリーの1階層目は承認グループと呼ばれるもので、承認を開始するためには承認グループの次の階層で表示されている承認ルートを選択する必要があります。

承認ルートを選択すると、[承認順番]の欄にユーザ名が表示されます。

備考

一覧に戻る


複数のファイルを選択して承認依頼するとどうなりますか？

最終更新日：2000年9月26日
文書番号：CH1000020012

概要

この資料は承認に関する説明です。

詳細

すべてのファイルに同じ承認表題が設定されて同時に承認が開始されます。

備考

一覧に戻る


[承認状況]で誤って[削除]を押してしまいました。状況を確認する方法はありますか？

最終更新日：2000年9月26日
文書番号：CH1000020013

概要

この資料は承認に関する説明です。

詳細

承認状況で[削除]を実行すると、削除した承認表題の承認状況を再び表示することはできません。[削除]ボタンは慎重にクリックするようにして下さい。

備考

一覧に戻る


[チェックアウト状況]でチェックアウトされているはずのファイルが表示されません

最終更新日：2002年2月4日
文書番号：CH1000020014

概要

この資料はチェックアウトに関する説明です。

詳細

[チェックアウト状況]ウィンドウは起動直後に自分のチェックアウトしたファイルのみ表示するように設定されています。他人のチェックアウトしたファイルも含めてすべてのチェックアウトファイルを表示したい場合は、[表示]－[自分のファイル]のチェックを外してください。

また、チェックアウト状況を開いた状態でファイルをチェックアウトした場合、チェックアウト直後のファイルは一覧に表示されていない場合があります。このような場合は[表示]-[最新の情報に更新]を実行してください。

備考

一覧に戻る


登録したファイルが全文検索で見つかりません

最終更新日：2000年9月26日
文書番号：CH1000030015

概要

この資料は全文検索に関する説明です。

詳細

登録ファイルが全文検索にヒットしない原因として次の２つが考えられます。

  1. サーバの準備が完了していない。
    登録したファイルが全文検索可能になるには、通常で数分かかります。サーバの負荷および登録したデータの数により30分程度かかる場合もあります。
  2. 登録されたファイルが全文検索対象ファイル種ではない
    全文検索の対象となるファイルはMSOffice製品（ワード、エクセル、パワーポイント）、PDF、HTML、TXTです。

備考

一覧に戻る


個人バーチャルフォルダの下に、［検索結果］フォルダがたくさんあって邪魔です

最終更新日：2000年9月29日
文書番号：CH1000030016

概要

この資料はオプションに関する説明です。

詳細

クロノスターでは検索を実行すると自動的にバーチャルフォルダが作成されます。この自動的に作成されたバーチャルフォルダはクロノスター終了時に削除するようにオプションで設定することができます。

  1. メインウィンドウから[ツール]－[オプション]を選択して[オプション]ウィンドウを表示します
  2. [検索]タブを選択します
  3. [終了時に検索結果フォルダを削除]チェックボックスをチェックします
  4. [OK]でオプションウィンドウを終了します

備考

名前を変更した検索結果のバーチャルフォルダは終了時に削除されません。

一覧に戻る


似ている画像なのに見つかりません

最終更新日：2000年9月29日
文書番号：CH1000030017

概要

この資料は画像検索に関する説明です。

詳細

画像検索では以下の手順で類似する画像を検索します。

  1. 登録ファイルを画像検索対象に追加
  2. サーバプログラムが画像検索対象のファイルを解析して学習する
  3. 検索が実行し、サーバに構築された類似画像マップから類似画像リストを取得

従って、以下の場合に予想した画像が見つからない可能性があります。

  1. 目的の画像が類似検索対象になっていない
    登録された画像ファイルは、オプションで即座に類似検索対象になるように設定されてない場合、管理者の設定した時間に定期的に類似画像対象に追加されます。
    また、画像検索の対象となるファイル形式は、JPEGおよびBMPのみです。
  2. 学習が十分でないか、学習の結果プログラムが似ていないと判断している
    画像検索のための解析プログラムの状態によって、類似画像検索の結果は異なります。

備考

一覧に戻る


ボタンが無効になっていて選択できません

最終更新日：2000年9月26日
文書番号：CS1000000001

概要

この資料はシステム管理者ツールに関する説明です。

詳細

購入されたライセンスによっては使用できない機能があり、それらのボタンは無効となります。

また、ライセンスの設定がされていないサーバでは、すべてのボタンが無効となります。

備考

一覧に戻る


あるグループに設定した権限を別のグループにコピーできますか？

最終更新日：2000年9月26日
文書番号：CS1000010002

概要

この資料は属性設定に関する説明です。

詳細

権限設定はサーバに登録されたファイルを保護する為の重要な操作である為に設定内容を確認しながら慎重に行ってください。そのような理由からコピー機能は装備していません。

備考


設定したグループがツリーに表示されません

最終更新日：2000年9月26日
文書番号：CS1000010003

概要

この資料は属性設定に関する説明です。

詳細

新規に作成した属性グループがシステムフォルダのツリーとして表示されない原因として次のことが考えられます。属性設定を変更することで正しく表示されるようになります。

  1. システムフォルダの階層設定を行っていない場合
    最低ひとつ以上の属性項目にシステムフォルダ階層設定が必要です。システムフォルダとする属性項目を選択し、｢システムフォルダの階層｣に1以上の値を設定します。
  2. システムフォルダの階層に設定された属性項目に属性値がない場合
    システムフォルダの階層に設定された属性項目は最低1つ以上の属性値を設定する必要があります。その属性値がフォルダとして表示されるからです。
  3. 読み込み権限がない場合
    権限設定を使用するように設定しているサーバの場合、新規に作成した属性グループは、すべてのユーザに使用権限がない状態となっています。属性グループを選択し、｢権限｣ボタンをクリックします。システムフォルダを表示させたいユーザには読み込み権か書き込み権の権限設定を追加してください。

備考

一覧に戻る


HDDを増設したいのですが、データを移行できますか？

最終更新日：2000年9月26日
文書番号：CS1000020005

概要

この資料は領域作成に関する説明です。

詳細

既存のデータ領域をそのまま使用しながら新たに増設したHDDの領域をデータ領域に追加する場合には、標準の管理ツールで簡単に設定できますが、既存の領域を新たに増設したHDDの領域に移動する場合には特別な操作が必要で、現在そのためのツールは用意していません。

このような場合にはサポートにお問い合わせください。

備考

現在、標準的なデータ移行ツールの作成を検討中です。

一覧に戻る


[キャッシュ領域]の意味がわかりません

最終更新日：2000年9月26日
文書番号：CS1000020006

概要

この資料は領域作成に関する説明です。

詳細

キャッシュ領域とはリムーバブルメディアに転送したデータのサムネイル情報を保持する領域で、これによりリムーバブルメディアに転送されたファイルに関しても高速な検索とサムネイルの表示ができるようになっています。

備考

一覧に戻る


誤って領域を作成してしまいました

最終更新日：2006年2月10日
文書番号：CS1000020007

概要

この資料は領域作成に関する説明です。

詳細

ファイルが登録されるまでは削除可能です。

備考

一覧に戻る


承認ユーザにNTのグループを指定できませんか？

最終更新日：2000年9月26日
文書番号：CS1000030008

概要

この資料は承認ルートに関する説明です。

詳細

承認ユーザにグループを指定することはできません。グループに対して承認を依頼する運用をしたい場合には、エイリアスを設定するなどして対処してください。

備考

一覧に戻る


選択可能ユーザが表示されません

最終更新日：2000年9月26日
文書番号：CS1000030009

概要

この資料は承認ルートに関する説明です。

詳細

以下の2つの状況が考えられます。

  1. NTドメインが認識されない
  2. 承認ルートではなく、承認グループが選択されている
    承認グループ設定の一番左のツリーは承認グループの下に承認ルートを設定するようになっています。承認ユーザは承認ルートに対して設定しますので、承認ルートを選択して設定を行うようにして下さい。

備考

一覧に戻る


登録を拒否したいファイルの拡張子が表示されません

最終更新日：2000年9月26日
文書番号：CS1000040011

概要

この資料は信頼性エージェントに関する説明です。

詳細

[フィルタ／コンバータ設定]ウィンドウではファイルの拡張子をドロップダウンリストから選択するようになっていますが、手入力することもできるようになっています。

ドロップダウンで表示されない拡張子もキーボードから直接入力することで設定することができます。

備考

一覧に戻る


[警告許可]を設定するとどうなりますか？

最終更新日：2000年9月26日
文書番号：CS1000040012

概要

この資料は信頼性エージェントに関する説明です。

詳細

[警告許可]を設定すると、登録結果のダイアログで警告メッセージが表示されます。

この設定は、特定のアプリケーションが将来使えなくなると分かっているような場合に、ユーザに登録を控えるように警告するような使い方があります。

備考

一覧に戻る